Ask Your Question
0

Calc formula not appearing in clipboard or pasting into another sheet

asked 2019-08-30 22:28:13 +0200

jamesb gravatar image

updated 2019-09-05 18:24:41 +0200

erAck gravatar image

Having searched around I have only found answers to this which relate to systems running Wayland. As I'm using x11 I am unable to discover why Ctrl-C (or Edit/Copy) followed by Shift-Ctrl-V (or Edit/Paste Special) only copies and pastes the result and not the formula from one Calc sheet to another.

Anyone got any insights?

(I'm using LibreOffice 6.3 on Ubuntu 18.04 LTS.)

edit retag flag offensive close merge delete

Comments

After clicking on the cell in question, try highlighting and copying the formula from the Input Line (above the spreadsheet).

ve3oat gravatar imageve3oat ( 2019-08-31 00:01:19 +0200 )edit

Hi ve3oat

Thanks for taking the time to reply.

Yes, your suggestion would and does work fine. However, Ctrl-c should (and previously has) copied the formula, not just the result.

I'm still hoping that someone has found out the root cause of this issue and can enlighten me. :-)

jamesb gravatar imagejamesb ( 2019-08-31 13:19:51 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-08-31 17:39:53 +0200

jamesb gravatar image

updated 2019-09-04 12:13:48 +0200

So...

The problem has gone away, but I don't know why!

Here's what I did:

1 - Install Gnome desktop (I already had KDE) thus:

$ sudo tasksel install ubuntu-desktop

2 - Logout, and login with Gnome

3 - Check copy and paste -- it worked fine, all formats preserved

4 - Reboot (there were updates which demanded I do so)

5 - Login with Plasma (KDE)

Now copy and paste in KDE also work fine, all formats preserved.

This seems - for now at least - to have fixed the clipboard issue. I hope it doesn't return. Perhaps this information will be of use to someone else, one day, too!

EDIT

The problem came back. I logged out of KDE, and logged in again. The problem had vanished. Clearly re-starting the KDE session fixed the fault, for now at least. I wonder how long it will stay fixed this time...

FURTHER EDIT

The problem came back again. But this time I noted it appeared after starting KRDC remote desktop connection client. So I did some testing. Now, many tests later, and a whole day, the problem seems to have stayed away. My solution was to uninstall KRDC remote desktop connection client, and use Remmina remote desktop client.

edit flag offensive delete link more

Comments

Might be some clipboard destroyer (aka "manager") gets in the way, most of them are too dumb and pull just the text/plain type (or maybe some html or image formats as well) from the formats offered by the application, effectively ignoring everything else so the pasting application doesn't see the other formats, i.e. here the Calc internal clipboard data.

If it works in a fresh KDE session that might be an indicator as then for the first paste the clipboard destroyer might not be involved yet and only gets in the way if multiple clipboard actions are stacked.

erAck gravatar imageerAck ( 2019-09-03 14:52:25 +0200 )edit
1

Hi erAck See my "Further edit". Seems KRDC remote desktop connection client is breaking clipboard.

jamesb gravatar imagejamesb ( 2019-09-04 12:14:26 +0200 )edit

Thank you for providing the solution to your problem!

erAck gravatar imageerAck ( 2019-09-05 18:23:31 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-30 22:28:13 +0200

Seen: 71 times

Last updated: Sep 04