Ask Your Question
0

Eliminate gap between tables without dragging tables? [closed]

asked 2019-09-02 06:41:12 +0200

appreciatethehelp gravatar image

updated 2019-09-10 03:54:58 +0200

OSX Mojave, Libreoffice 6.2.5

Occasionally I end up in a situation where two tables exist, with a manually-formatted space between them (line break/breaks), and I want to remove this space, so that they are both touching teach other at their bottom/top borders. Currently the way I have been doing this is by selecting the bottom table then dragging it up to touch the top one, then deleting the empty, leftover table that remains. The problem with this method is that it then needs to be repeated for any further tables below; to eliminate the space between them and the bottom table, I again end up dragging them up to meet it, then deleting the left-over empty remaining table. This process gets old when it needs to be repeated x number of times for the number of tables in the document.

So, how do I remove the (manually formatted) space between tables using a different method- one that doesn't require dragging and deleting every last table below the manually-formatted space?

Cheers.

Edit @ Mike Kaganski & Ajilittoz: once set to be displayed via View > Formatting Marks I can't remove the paragraph mark pilcrow by selecting it/the line it's on and pressing delete; I get no response from doing this- the pilcrow, and thus the space, remains.

FINAL EDIT/QUICK ANSWER: on mac, be sure to press del (Fn + Backspace) not backspace, to remove the paragraph break, and thus the gap between the tables.

C:\fakepath\Remove paragraph mark pilcrow between tables.odt

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by appreciatethehelp
close date 2019-09-10 21:53:52.751078

Comments

What you describe happens inside the table because they only contain an empty paragraph and you can't get rid of the last remaining paragraph in a cell. A truly empty cell is nonsense, there must be at least one object in it.

Similarly, the last paragraph mark in a document can't be disposed of.

There is no need to select the mark (unless you want to delete several ones in a single shot), just put the cursor before it.

ajlittoz gravatar imageajlittoz ( 2019-09-08 07:50:30 +0200 )edit

What is different in your edit? I still experience correct behaviour with your sample file.

ajlittoz gravatar imageajlittoz ( 2019-09-08 11:47:23 +0200 )edit

I am referring to the space between the two tables in the attached document- if I put my cursor on the line containing the pilcrow between the two tables and press delete, nothing happens, again leaving me in a position where the only way I can see to remove this space is to drag the bottom table up to the top one to eliminate the gap, then delete the empty leftover remaining table.

appreciatethehelp gravatar imageappreciatethehelp ( 2019-09-09 07:39:50 +0200 )edit

"There is no need to select the mark (unless you want to delete several ones in a single shot), just put the cursor before it." For what it's worth I can't select any of the pilcrows; they are unclickable.

appreciatethehelp gravatar imageappreciatethehelp ( 2019-09-09 07:44:34 +0200 )edit

Have you taken into account @Mike Kaganski's remark? You must press simultaneously Fn+Backspace to get Del.

ajlittoz gravatar imageajlittoz ( 2019-09-09 07:57:12 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-09-02 11:39:52 +0200

ajlittoz gravatar image

There's no need to drag, but you must be able to "see" the empty paragraphs and distinguish them from spacing set by Table>Properties.

Enable View>Formatting Marks. Paragraph marks are now displayed as "pilcrows" (mirrored Ps).

Put the cursor in an empty paragraph and press Del.

If space remains between your tables, check Table>Properties, Table tab for spacing setting. Check also Text Flow tab as suggested by @Mike Kaganski.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more
1

answered 2019-09-02 08:39:34 +0200

updated 2019-09-08 13:13:34 +0200

You need to remove any (possibly empty) paragraphs between the tables (if any) first; in the process, even if the second table initially had not a "break page before" property, it will get one (moved from the removed paragraphs). So the second step is to open the second table's properties at the Text Flow tab, and uncheck the [ ] Break checkbox.

EDIT re: "I can't select and remove the pilcrow between the tables by selecting the line and pressing del- nothing happens, and the space is due to it":

It must be due to the fact that on macOS, the Del behaves differently compared to other OSes: it is like Backspace by default, and only behaves like Del on other OSes, when used with fn key - see here. Since Backspace has no effect in the case, you need to use fn+Del (or Control+D) on macOS in the empty paragraph.

edit flag offensive delete link more

Comments

Hi Mike, how do I remove said paragraphs between the tables? The only way I know how is to drag bottom table up to meet top one, then delete empty leftover table, as mentioned in question.

appreciatethehelp gravatar imageappreciatethehelp ( 2019-09-02 22:20:52 +0200 )edit

As I said: you need to remove them if any exist (i.e., if you can put a cursor there and press Del/Backspace). If they don't exist, you go straight to the following part, changing the table properties.

I am sure you display Formatting Marks in the document to see exactly what you do, don't you? ;-)

Mike Kaganski gravatar imageMike Kaganski ( 2019-09-02 22:26:22 +0200 )edit

@Mike Kaganski, please see edited question: I can't select and remove the pilcrow between the tables by selecting the line and pressing del- nothing happens, and the space is due to it- not table spacing/other factors.

appreciatethehelp gravatar imageappreciatethehelp ( 2019-09-08 03:05:32 +0200 )edit

@Mike Kaganski: laptop Mac's have a "reduced" keyboard without Del key. In fact, the key is a Backspace key, located as usual in the upper right of the alpha keyboard. There is a numeric keypad at right but no "function" key in-between where yoiu find traditionally the Del key.

Thus your explanation (which is right anyway) works the other way round: keyboard has a real Backspace and Fn is used to obtain the alternate semantics. I had forgotten this fact.

ajlittoz gravatar imageajlittoz ( 2019-09-08 14:52:30 +0200 )edit

@ Ajilittoz That's it; when you said "del" I thought you meant "backspace" on mac, hence the lack of result. Fn + Backspace worked.

I'm too used to converting windows keys to their mac equivalents from my bad habit of not detailing my OS in the question and thus receiving windows-geared responses. Lesson learned.

appreciatethehelp gravatar imageappreciatethehelp ( 2019-09-10 03:50:51 +0200 )edit

There's not only Windoze and MacOS in life: Linux and others are here ;-)

In this explanation, there are two levels: the keycode to trigger the action (it is OS-independent) and where that key is located (OS and OS-variant dependent). Where MacOS is specific is related to the Ctrl key which must be replaced by the "clover" key .

ajlittoz gravatar imageajlittoz ( 2019-09-10 08:06:10 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2019-09-02 06:41:12 +0200

Seen: 61 times

Last updated: Sep 10