How to configure compilation of LibreOffice Basic? [closed]

asked 2019-09-06 16:51:31 +0200

4459 gravatar image

updated 2019-09-07 22:05:34 +0200

Hi, I have library of macros in Calc, which are printing messages that include local characters (czech). When the library is unlocked, messages are shown correctly. But when I set password for the library, reopen the document and trigger the same macro, "?" is shown instead of local character - I have to use "chr$(269)" command to display the character. Interesting is, that when library is unlocked for editing, messages are shown correctly. Is there any way to force specific code page for Basic macros, so I can use regular strings for messages?

Thank you for answer.

EDIT: So I figured out where is the problem - when i export the library without any password, code is stored as xml encoded in UTF-8. But when I export library with password, macros are stored in .pba archive that contains files "code.bin" and "source.xml" both with ton of unprintable characters. In "code.bin" are some messages readable and contains "?" instead of local characters - just as they are printed. Therefor I changed question. Is there any way to configure compilation of LibreOffice Basic to force UTF-8?

EDIT: This is known issue - bug 57113. Unfortunately unfixed until today.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by 4459
close date 2019-09-07 22:06:07.613984

Comments

It actually looks like a bug - please file it to the bug tracker.

tdf#57113

Mike Kaganski gravatar imageMike Kaganski ( 2019-09-07 22:02:45 +0200 )edit