Ask Your Question
1

Calc thinks a file has macros but it doesn't

asked 2019-09-06 21:31:17 +0200

LewG2 gravatar image

updated 2019-09-06 21:50:31 +0200

I just installed ubuntu 16.04 and upgraded to LO 6.2.7.1

When I open a file, calc interrupts me with a warning about macros. I have macros, but none stored in files. See below.

I don't know what version LO I was using before, but for some time when this file opened, it immediately flagged it as edited/dirty. Before I did anything to it. How can I get rid of this false message? If I disable macros as it suggests, will it affect only that file or all?

image description

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2019-09-08 20:01:06 +0200

Ratslinger gravatar image

Hello,

You do not need a macro within the document itself for the message to be generated. In fact, there doesn't even need to be a macro but simply a reference to one.

In a test document, there are no macros within the document:

image description

However, there could be a reference to a macro within My Macros & Documents or even a Python macro not seen in the Basic IDE:

image description

This was in Tools->Customize and the referred to macro does not even need to exist - the message will be generated. There can be other places within the document a macro was referenced also creating the same message. You need to find the reference(s) and fix.

When opening the document and getting this message:

image description

clicking Disable Macros only disables macros for this document while it is open. Closing & reopening will produce the same dialog.

edit flag offensive delete link more
1

answered 2019-09-07 11:39:04 +0200

Opaque gravatar image

updated 2019-09-07 12:22:41 +0200

Hello,

may be the answer to this question also fixes your problem. Though it is about Writer, you may also have an empty Macro Library causing the message. Therefore check tab Libraries on the dialog shown in your screenshot.

Answer to additional question: Macro security is global setting of the application (by nature - otherwise each document could state Trust me, I have macros enabled)

Hope that helps.

If the answer is correct or helped you to solve your problem, please click the check mark (✔) next to the answer.

edit flag offensive delete link more
0

answered 2019-09-10 15:46:18 +0200

LewG2 gravatar image

Thank you, Ratslinger and Opaque. Now I know some other places to check if macros start acting up.

I found no empty macro library and no Assigned Actions (at all) in my Tools>Customize>Events display.

I did click Disable Macros for the file, and it has not occurred since then in that file or others.

To be complete, after installing LO 6 from the website, I did notice other differences in behavior, and I installed LO 5 calc and writer from Ubuntu Software. I don't know if that also made a difference.

So I seem to be ok. Thanks again for your help.

edit flag offensive delete link more

Comments

@LewG2,

Please do not use an answer unless it answers the original question. This should simply be a comment under the answer you are responding to.

Ratslinger gravatar imageRatslinger ( 2019-09-10 16:23:22 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-09-06 21:31:17 +0200

Seen: 68 times

Last updated: Sep 10