Ask Your Question
0

LO6 Spreadsheet not calculating fields.

asked 2019-09-07 17:28:11 +0100

Jrflanne gravatar image

updated 2020-07-11 00:54:34 +0100

Alex Kemp gravatar image

I am running LO6 with OS X. Something got reset. If I create a new sheet, put a value in A1 and enter in B1, "=A1 and hit enter, nothing happens. It just displays "=A1". Data>Calculate>AutoCalculate is on and if I select Data>Calculate>Formula to Value, it displays the value. This has always worked so it must be a setting but I cannot find it. Anybody have any idea what happened?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-09-07 18:34:59 +0100

jodybingo gravatar image

Check the formatting for the cell B1 and make sure it isn't set to Text (under the Numbers tab). If it is, set it to All and re-enter your formula

edit flag offensive delete link more

Comments

Well, not that. When I change B1 to an integer, B2 displays "=B2" but becomes right justified. It seem to think it's numeric, the format is numeric general, but it's broken. I might add I believe this started from when I opened a file received from a data vendor. Opened fine, but this edit issue began. Exported to csv, opened that but still can't calculate a new field.

Jrflanne gravatar imageJrflanne ( 2019-09-07 19:31:25 +0100 )edit

besides other influendes be aware that reformatting a cell - applying e.g. 'text' vs. 'number' - does not! work instantly, the content of the cell - the value or formula - needs to be changed or at least 'touched' for the format change to come into effect (an unchangig edit as appendig an "" at the end and deleting it while still in edit mode, thus saving the same content as before is sufficient). That's why @jodybingo wrote "... and re-enter your formula".

newbie-02 gravatar imagenewbie-02 ( 2019-12-14 11:01:34 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-09-07 17:28:11 +0100

Seen: 82 times

Last updated: Sep 07 '19