Ask Your Question
0

Writer: Date in footer always resetting to MM/DD/YY

asked 2019-09-08 15:50:24 +0200

vittopascu gravatar image

updated 2019-09-08 19:15:19 +0200

Dear all,

I am using LibreOffice v 6.3.1.2 on Windows 7 64bit. However I have the same issue on Linux Mint 19.1 & 19.2 on several past stable versions of LibreOffice.

I live in europe so I prefer using the DD/MM/YY format. I have a self-made "Writer" template where I have a header and a footer in each page, although the first page is slightly different. I have a date field in the footer booth in the first page and any other page footer.

I set such date fields to the DD/MM/YY format and the field gets displayed correctly. I only need to change the field format on the second page and it will automatically propagate to all other pages (except for the first one). However if I save, close and re-open the document, I will find that in the first page the date format is still correct while in all other pages the date format has reverted to MM/DD/YY.

Is this a bug or am I missing something? Thank you very much.

C:\fakepath\Example Template.odt

edit retag flag offensive close merge delete

Comments

We can't tell without more technical information. Please edit your question to attach your template (with the "paperclip" tool). While you're at it, mention your OS and LO version.

Do you make the change in the template or directly on the document? When you reopen the document after a template change, do you get the dialog asking for style update?

ajlittoz gravatar imageajlittoz ( 2019-09-08 18:48:33 +0200 )edit

Thank you for your quick answer. I edited the question as you requested (hopefully). I tried to make the required change and then "save as template". Then I open a new document from the template and I find again that the second page has the MM/DD/YY format, even though I saved it with DD/MM/YY

vittopascu gravatar imagevittopascu ( 2019-09-08 19:21:02 +0200 )edit

Works here. How do you save? Did you forget to force filetype to template with .odt extension? Sorry for the question, cross-posting you know.

ajlittoz gravatar imageajlittoz ( 2019-09-08 19:24:11 +0200 )edit

Looks somewhat similar to tdf#127241, which we cannot reproduce yet...

Mike Kaganski gravatar imageMike Kaganski ( 2019-09-08 19:52:20 +0200 )edit
1

Check whether Language specification turned to Automatic after you have specified your format for page 2. I do also see what you describe and could overcome the behavior by (re-)specifying the format under Additional formats and -important- setting Language different to Automatic.

Opaque gravatar imageOpaque ( 2019-09-08 20:03:21 +0200 )edit

Ok thank you very much for your hint. Indeed, I did what you suggested and now it works! My default language for documents is English USA, so explicitly specifying Englis USA as the field language solved the problem

vittopascu gravatar imagevittopascu ( 2019-09-08 23:32:32 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-09-09 10:09:43 +0200

Opaque gravatar image

For the records (according to last comment of @vittopascu )

Check whether Language specification turned to Automatic after you have specified your format for page 2. To vercome the behavior (re-)specify the format under Additional formats and set Language different to Automatic (e.g. set to English (USA)).

Screenshot (after change from Automatic to English(USA))

image description

edit flag offensive delete link more

Comments

Awesome, thanks for making it so clear :)

vittopascu gravatar imagevittopascu ( 2019-09-09 10:33:36 +0200 )edit

Please consider to click the check mark (✔) next to the answer to show others that there is a cprrect answer which helped to fix a problem

Opaque gravatar imageOpaque ( 2019-09-09 10:36:07 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-09-08 15:50:24 +0200

Seen: 35 times

Last updated: Sep 09