Ask Your Question
0

AskLibO: message waiting icon frozen to red

asked 2019-09-11 18:48:14 +0200

ajlittoz gravatar image

I was subscribed to a question for having commented or already answered it, so received notifications when question/answers/comments were edited.

I received a notification and the message waiting icon turned red. I opened the "notifications" tab of my account to see what was at stake. I clicked on a yellow background item (unread notification) and I got "content no longer available": original poster deleted his question before I could read the edit. Consequently, the notification is not read and the flag remains red.

I hoped that when the notification would scroll past the end of page, the icon would be cleared. This did not happen. All my "notifications" page has now a white background (no unread message) I still get "You have 5 new responses". It is rather embarassing because I can no longer rely on the icon color for my traffic.

Does an old-timer on this site know how to clear the icon?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-09-27 17:58:32 +0200

ajlittoz gravatar image

I finally found a solution.

The problem is the Activity screen displays only one page worth of "journal": there is no button/link to go to next or previous page. Consequently, if a non-acknowledged message scrolls off the bottom, there is no longer any way to access it and to mark it read.

So how to scroll back the unread messages?

I marked all notifications, then I deleted them. This brought back a pageful older notifications. I did it again until the unread messages showed on screen. Then it was easy to mark them read.

The trouble was created by a race condition: when I tried to acces the question, OP had already deleted it. Therefore, I could not access the question and AskBot would not automatically mark it read.

So, my advice: when this happens to you, immediately mark the notification(s) read manually.

edit flag offensive delete link more
0

answered 2019-09-11 20:17:43 +0200

RGB-es gravatar image

Click on "select all" and then on "mark seen" to clean everything. And yes, it's weird.

edit flag offensive delete link more

Comments

Doesn't work The reason is the "offending" notification has scrolled past the end of the list.

I tried to contact people on IRC #tdfinfra but they advised me to report a bug against AskBot.

ajlittoz gravatar imageajlittoz ( 2019-09-11 21:18:57 +0200 )edit

I had new notifications. I read the questions/comment. This cleared the yellow background but message waiting is still red. Very puzzling!

ajlittoz gravatar imageajlittoz ( 2019-09-14 09:18:11 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-09-11 18:48:14 +0200

Seen: 160 times

Last updated: Sep 27