Ask Your Question
0

How to keep language setting for cells?

asked 2019-10-04 17:57:24 +0200

The default for my sheet is English, but in some cells I need to have currency in German, that is, with comma instead of decimal point. I can change "language" for the cell (font and currency) to German, then the amount is shown correctly. Then I save it, but when I open the file again, every cell is in English format (both font and currency). Saving in .ods or .xlsx format makes no difference.

edit retag flag offensive close merge delete

Comments

Which version of LibreOffice are you using on which operating system. Just made a test on one of my systems (LibreOffice 6.3.2.2 on openSUSE Leap 15.1) and I cannot confirm the behavior (which I would probably rate a bug).

Opaque gravatar imageOpaque ( 2019-10-04 18:03:45 +0200 )edit

XLSX doesn't have concept of cell language. That's something you can't set using Excel. Use native ODF.

Mike Kaganski gravatar imageMike Kaganski ( 2019-10-04 18:04:54 +0200 )edit

I'd advise to create a dedicated style for those cells.

gabix gravatar imagegabix ( 2019-10-04 18:12:05 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2019-10-08 11:58:50 +0200

erAck gravatar image

The font language is completely irrelevant for this. You need to set the number format's language to "German (Germany)" and then from Category pick Currency and then one of the currency formats.

edit flag offensive delete link more
-1

answered 2019-10-08 08:41:50 +0200

I am also having this problem. I am saving as .ods but it seems that cells do not retain their language setting for text -- only for numbers.

I have a sheet in English that also has some German cells. The only thing that seems to work (but not always) is to set the language for individual words using Format > Character > >Font Tab > Language

However, this is quite tedious.

Any tips?

edit flag offensive delete link more

Comments

1

tips?

Well - first please provide steps to reproduce.

Specifically, I have tested this:

  1. Create a new spreadsheet;
  2. Select all, and set cell format to Text (@) using direct formatting (right-click->Cell Format)
  3. Select B2:C3, right-click->Cell Format, set Language to en-UK on Font tab (from default, which was ru-RU for me)
  4. Save and reload
  5. Check the language of B2:C3.

It was kept. So - what specifically doesn't work for you?

And yes, please follow the @Opaque's (deleted) advise: don't "answer" when you don't provide a solution to the asked question. Use comments, or file your own questions if needed.

Mike Kaganski gravatar imageMike Kaganski ( 2019-10-08 08:49:03 +0200 )edit

only thing that seems to work

If it works, create a dedicated cell style, assign a shortcut and apply as necessary.

gabix gravatar imagegabix ( 2019-10-08 10:19:07 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-10-04 17:57:24 +0200

Seen: 20 times

Last updated: Oct 08