Ask Your Question
0

How do I stop text from turning into functions?

asked 2019-10-10 05:27:00 +0200

Morpheus918 gravatar image

Whenever I type certain words into a field in Calc, they are automatically turned into a function followed by parenthesis. For instance if I write the word "at", it changes it to "ATAN()", which means arctangent and is used to calculate something I have no interest in. This has happened with other words for other functions as well. Can someone share how I can turn this feature off? Thanks!

edit retag flag offensive close merge delete

Comments

But, only happend if you first type symbol =, not?

mauricio gravatar imagemauricio ( 2019-10-10 05:47:10 +0200 )edit

Yup, that was the issue. Actually, I was using the - sign, making a list using bullet points... Thanks!

Morpheus918 gravatar imageMorpheus918 ( 2020-01-13 19:05:45 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2019-10-10 08:04:51 +0200

keme gravatar image

updated 2019-10-10 08:07:39 +0200

Input starting with =, + or - will tell Calc to expect a formula. With that, you get automated suggestions for function names in many cases.

I routinely disable all autocorrect options and autoinput (on the Tools menu) and also untick "Extended tips" in Tools - Options, LibreOffice - General. This seems to reduce the number of cases where function suggestions occur. However, in some cases such as when you backspace to a possible function name, the suggestion pops up anyway.

The expected solution would be to format cells as text cells when you don't want formula help. This defeats all calculation and accepts input verbatim, except that those function suggestions still pop up if initial character is as indicated above. Looks like a bug to me.

A workaround: start input with an apostrophe ('). This will tell Calc that input is to be interpreted as verbatim text, and no suggestions will pop up (as far as I have checked it). This is how "format cell as text" also should work. That leading apostrophe will not show in the cell grid display and not be part of cell content, but it will show with the content preview in the formula bar in some cases.

Pitfall: if the cell is already formatted as text, a leading apostrophe will become part of the cell content (and as such, show up in the cell grid display).

edit flag offensive delete link more

Comments

NEWER BUG: What you say about the apostrophe not showing up when the first character in the cell grid display is NOT the case for Calc in Office V6.3.1.2(x64). The resulting cell that in my case shows '+5V is a bit confusing for those of us that started way back in the Macintosh Excel days and have used MANY spreadsheets that do as you say. Problem is not solved by formatting as Text for that cell or column, as entering the "+5V" without the apostrophe gives "+VALUE()" in cell. There is a workaround, if the column is formatted as text, start by entering '+5V, enter, then return to the cell and backspace out the apostrophe ("How quaint!" to quote Scotty in the Star Trek whale movie as he was trying to give a Macintosh voice commands).

RWatkins gravatar imageRWatkins ( 2020-03-18 21:20:40 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-10-10 05:27:00 +0200

Seen: 152 times

Last updated: Oct 10 '19