Ask Your Question
0

LibreOffice is not typing in CTL fonts ( Hindi / Malayalam ) ? [closed]

asked 2013-08-08 06:02:01 +0200

Gaurang Agrawal gravatar image

updated 2015-11-07 11:17:28 +0200

Alex Kemp gravatar image

I had LibreOffice 3.7 installed , which is displaying all CTL Fonts ( hindi / malyalam / punjabi and other languages ) but isn't typing in them . I upgraded LibreOffice to 4.1 , but it doesn't resolves it . I presume that this has to do something with Unicodes but I am clueless .

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-07 11:17:52.850038

Comments

Please indicate your operating system as the process differs according to this aspect.

oweng gravatar imageoweng ( 2013-08-31 00:58:32 +0200 )edit

4 Answers

Sort by » oldest newest most voted
1

answered 2013-08-31 01:30:08 +0200

oweng gravatar image

updated 2013-08-31 01:41:11 +0200

The process for setting up LO to allow typing in a script that differs from the language of the install is a multi-step one that requires:

  1. Install of LO language pack e.g., the DEB package for x86_64 architecture for Hindi (hi) and Malayalam (ml) can be found here.
  2. Install of a supporting font.
  3. Selecting of a keyboard layout.
  4. Use of an input method (in some cases).
  5. Configuring LO language settings.
  6. Selecting of the default font to use in LO.

I indicate the basic process in my answer here for Telugu under Fedora. The basic LO language settings required for Hindi are outlined in my answer here but please note the answer beneath this for selecting the required keyboard layout. Step #4 is sometimes also chosen by people who require an alternate input method (e.g., I-Bus).

edit flag offensive delete link more
0

answered 2013-08-30 13:55:31 +0200

Did this issue get solved for you? I am facing the same problem with the vanilla LibreOffice 4.1 I downloaded. No such issue is encountered in 3.5.4 which comes with my system. If anyone else has an idea for sorting it out, do please comment. Thanks.

edit flag offensive delete link more
0

answered 2013-08-08 09:32:04 +0200

L-user gravatar image

Don't know if this is solution... can you please look at the settings from: Tools | Options | Language Settings | Languages and check what are you settings there.

edit flag offensive delete link more
0

answered 2013-08-30 17:25:58 +0200

David gravatar image

There is a previous Q&A about Chinese characters that expands on L-user's earlier reply. Would it provide some help for this problem, too?

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-08-08 06:02:01 +0200

Seen: 3,459 times

Last updated: Aug 31 '13