Version for OS

asked 2019-10-11 14:28:16 +0200

Budha gravatar image

Hello, What is the OS dependency of LibreOffice? To be precise, is there a minimum version of Libre Office I need to install, in order for it to work on Windows 7/10 or Ubuntu? Or is it OS independent?

Thanks and best regards, Budha

edit retag flag offensive close merge delete

Comments

Any particular reason why you don't want the newest version, or do I misunderstand your request?

If we know why, we may advise on a better strategy.

  • System requirements for current version is available here
  • Can't find specifics for older versions, but installers are available for download here, if you want to test for yourself
keme gravatar imagekeme ( 2019-10-11 14:48:37 +0200 )edit

The Application(with quite a few macros) I developed for LibreOffice was for Windows XP with LibreOffice version 4.1.0.4(I know, very old, it was 6/7 years ago). I plan to migrate it to a newer OS : haven't decided yet if it will be Windows 7, Windows 10 or Unix. So, would like to know if the old application I developed will still work with this newer OS ? If not, I want to estimate the amount of work that will be needed to make it work. Hope, this makes it clear

Budha gravatar imageBudha ( 2019-10-11 15:27:46 +0200 )edit

Any version of LibreOffice may run on Windows 7 or 10 (and actually any OOo version released for Windows, too: I e.g. have OOo 1.0.3 running on my Win10).

Wrt Ubuntu - you didn't tell Ubuntu version; it's not that easy. Anyway, you are welcome to test DEBs from LibreOffice archive on your chosen OS.

Mike Kaganski gravatar imageMike Kaganski ( 2019-10-11 20:59:44 +0200 )edit

Hi Mike, Thanks for your answer/help.

Budha gravatar imageBudha ( 2019-10-12 15:44:17 +0200 )edit