Ask Your Question
0

Possible to default set the thousands comma?

asked 2019-10-14 02:11:18 +0100

notanotherone gravatar image

There appears to be no setting to have an entire document permanently set for the thousands comma i.e. 5,000 instead of 5000. If I change or add a cell, it defaults to no comma. If I change one cell to say 2 decimal places, it defaults to no thousands comma. If I open a new sheet, it defaults to no comma.

I'd like the comma there forever. Please.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-10-21 03:00:58 +0100

notanotherone gravatar image

Thanks for the answers - but - the formatting doesn't stay as a default setting for new spreadsheets. When I open another sheet, the default is NO thousands comma separator.

edit flag offensive delete link more

Comments

This is not an answer but another additional question to your original one. Please, edit your question to include your request to have persistent change.

ajlittoz gravatar imageajlittoz ( 2019-10-21 08:08:03 +0100 )edit
0

answered 2019-10-14 09:22:30 +0100

ajlittoz gravatar image

updated 2019-10-14 09:22:49 +0100

I assume that your question is related to Calc. You tagged your question as common but I think there is no answer for Writer and Impress.

You must define a user formatting code.

  • select one of your cells with a to-be-formatted number
  • Format>Cells, Numbers tab
  • in Format code, enter #,###.## if it does not exist already in the list (otherwise select it)

    In case your number(s) may be larger then one million (billion), you need to specify the extra separator as #,###,###.## (#,###,###,###.##).

Select the cells to be formatted and apply your user-format to code to them.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

Even better, define the number format in a cell style derived from the Default style and apply that style to the selected cell range, instead of direct hard formatting.

In case your number(s) may be larger then one million (billion), you need to specify the extra separator

That is not true. The group separator will be repeated for large numbers.

erAck gravatar imageerAck ( 2019-10-14 16:30:39 +0100 )edit

@erAck: when I checked my format, the repetition didn't occur (though I thought it would). Did I make a mistake?

ajlittoz gravatar imageajlittoz ( 2019-10-15 08:16:54 +0100 )edit

I don't know :-P Make sure the comma in #,###.## is actually your locale's group separator, otherwise it would be just a literal character at that position, which then would not be repeated for larger numbers. But then again it would also be displayed as a leading character for smaller numbers.

erAck gravatar imageerAck ( 2019-10-15 12:37:55 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-10-14 02:11:18 +0100

Seen: 132 times

Last updated: Oct 21 '19