Ask Your Question
1

Writer: document language changes with keyboard layout - how to remove this behavior? [closed]

asked 2012-04-24 19:39:33 +0200

Sebastian gravatar image

updated 2015-10-20 20:49:42 +0200

Alex Kemp gravatar image

Hi,

using LibreOffice 3.5.2.2 Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f on Windows 7 64bit Pro I get the following 'error' (to me it is, others might want that):

After I set the program-wide default and document-wide language to English and start writing English text with a German keyboard layout, my document language changes to German.

New text takes the language of the keyboard layout it was written with (i.e. they keep the language even when the keyboard layout is switched back).

Now this might be a useful behavior for someone who wants to type a word or two in a language different from their native keyboard layout. But I want my documents in English, even though my native keyboard layout is in German. Writing in a non-native layout is not an option for me and would be a very messy workaround.

Any ideas what I could do to change this?

Thanks, Sebastian

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-20 20:49:57.664128

6 Answers

Sort by » oldest newest most voted
2

answered 2012-12-06 13:16:04 +0200

pallinger gravatar image

updated 2013-01-23 10:02:29 +0200

I think this feature of LibreOffice is a more of a bug, at least in the current form that it cannot be disabled.

I opened a bug in the libreoffice bug tracker: https://bugs.freedesktop.org/show_bug.cgi?id=57947

See: http://superuser.com/questions/417838/prevent-libreoffice-from-switching-language-on-keyboard-layout-change

Update: As @manj_k pointed out, this bug was fixed in libreoffice 4.0. So, if you use an older version, you could switch to the newer (albeit currently beta) one.

edit flag offensive delete link more

Comments

LO 4.0 is out of beta and is now the latest release :-)

qubit gravatar imagequbit ( 2013-02-25 06:41:44 +0200 )edit
3

answered 2012-12-06 17:56:51 +0200

manj_k gravatar image

updated 2012-12-06 18:00:44 +0200

( @pallinger )

There's a new option in LibreOffice 4.0:

Menu Tools → Options → Language Settings → Languages
☐ / ☑ Ignore system input language

Screenshot: LibO-Dev 4.0.0.0.alpha1+ (2012-12-03)
ignore_system_input_language

That should solve the reported problems ...

edit flag offensive delete link more

Comments

You might test the new option with → LibreOffice 4.0.0 Beta1 (2012-12-07)

manj_k gravatar imagemanj_k ( 2012-12-08 23:48:29 +0200 )edit
manj_k gravatar imagemanj_k ( 2012-12-09 19:20:13 +0200 )edit

Yes, I extended a bug report just to see later that it was already solved a few days earlier -- somehow I didn't find the other bug that contained the patch with the option in the bug tracker...

pallinger gravatar imagepallinger ( 2013-01-22 16:47:36 +0200 )edit
1

@manj_k Thank you man! That's the answer! I've been struggling for years with this problem (I write in 3 languages). It worked for me!

Beizerno gravatar imageBeizerno ( 2014-01-10 13:26:46 +0200 )edit
1

answered 2012-12-07 03:51:55 +0200

ROSt52 gravatar image

Does this problem also occur in other SW? E.g if you use Notepad?

If you have problems in Notepad, I would recommend to look for the basic keyboard and languages setting in the OS. I am using XP and I am not familiar with W7 to give you more detailed hints.

My experience:

When setting up a new PC I face this problem always and have to work in the OS until in Notepad all appears correct. Thereafter LibO workes also. I have to deal with 4 languages and one is a double byte language. No problem in LibO. Thus there should be a solution. I am using the LibO English US version as this is the multi-language version (I read somewhere). You can set up the GUI in German or English, install the language packs for German and English (and if needed or other languages). You must do a customized installation for the first time otherwise you get all languages.

edit flag offensive delete link more
0

answered 2012-04-25 11:14:50 +0200

manj_k gravatar image

It seems, that you have toggled the OS input language (Alt+Shift) to DE (German).

You might add the German keyboard layout to the English input language. [On WinXP: Control Panel > Regional and Language Options > Languages > Text Services and Input Languages > Details > Add... > Input Language English (USA), Keyboard Layout German (Germany)]

Maybe useful → http://windows.microsoft.com/en-US/windows7/Change-your-keyboard-layout

edit flag offensive delete link more

Comments

Thanks, nice idea. However this doesn't work either. Using the German keyboard layout with English as the input language doesn't change the behavior. This looks more or less like a bug to me...

Sebastian gravatar imageSebastian ( 2012-05-01 01:59:49 +0200 )edit
0

answered 2012-06-09 21:58:37 +0200

I found the solution trying stuff with keyboard configuration, you should add a language (English) and add your preferred keyboard (German in your case). That worked for me with a Swedish keyboard.

edit flag offensive delete link more
0

answered 2012-04-24 22:31:18 +0200

m.a.riosv gravatar image

Have you set the idiom to English in the default paragraph style? Menu/Format/Styles and formatting (F11)

edit flag offensive delete link more

Comments

Yes, I did. It is set to English. Still the same behavior. Even if I write the text with my German keyboard (which makes it German text for the writer) and then apply the default paragraph style, it remains German. Not cool.

Sebastian gravatar imageSebastian ( 2012-04-25 00:41:24 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2012-04-24 19:39:33 +0200

Seen: 5,962 times

Last updated: Jan 23 '13