Ask Your Question
0

get grid lines to show in calc

asked 2019-10-23 00:01:37 +0100

jbrid123 gravatar image

updated 2019-10-23 11:07:44 +0100

Opaque gravatar image

I cannot get grid lines to show. I've tried all the suggestions in a google search and they have no effect whatsoever. Why is this simple thing so hard? Very frustrating.....

[Edit Opaque] Moved answer to details of question and deleted answer

C:\fakepath\Sectional PreRegistrations Summary as of Oct 19.xlsx

I hope that upload worked. I tried view - view grid lines, did not work. I have no colored cells. Where do I reset user profile? You'll notice that half of the sheet has grid lines. That half is information I got from a user who uses Excel. Why is this very simple thing so hard in open office?

edit retag flag offensive close merge delete

Comments

1

I've tried all the suggestions in a google search

What does that mean exactly? Please provide a an empty file showing no grid lines (In general View -> [x] View Grid Lines activates the grid lines. but if you have colored cells things may be different. The default of LibreOffice is to show grid lines, so resetting your user profile could also be a choice to start over).

Opaque gravatar imageOpaque ( 2019-10-23 00:10:16 +0100 )edit

Sorry - but this happens, if people don't tell the full details. You should have told that you are talking about an alien (with respect to LibreOffice) format. The file is in .xlsx format and this is not the native format of LibreOffice. Thus there is no guarantee that an import works without any drawbacks. Reset of user profile won't help anything here.

Opaque gravatar imageOpaque ( 2019-10-23 11:10:07 +0100 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2019-10-23 11:46:40 +0100

Opaque gravatar image

updated 2019-10-23 11:48:31 +0100

Hello,

see the following file:

C:\fakepath\NoGridLinesCorrected.ods

The problem is in the page style PageStyle_elementor_Sectional_13092019_11, which seems to be inherited from Excel. To correct the problem do the following (with your origonal file, already done on the attached version):

  • Open the .xlsx file
  • Select all cells (click grey square at the intersection of row and colums headers) and Format -> Clear Direct Formatting ( or CTRL+M)
  • Go to Styles -> Manage Styles (or F11)
  • Select Page Sytsles (second icon of the two icons below the word Styles
  • Double click on entry Default (this will assign the default page style to the sheet)
  • Set Tools -> Options -> LibreOffice -> LibreOffice Calc -> View -> Option: Grid Line -> Dropdown: Show and click OK
  • Set View -> View Grid Lines
  • Go to Styles -> Manage Styles (or F11) and Right click on PageStyle_elementor_Sectional_13092019_11 and Delete
  • Save the file in .ods format.

Procedure tested using LibreOffice:

  Version: 6.3.2.2, Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
  CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: kde5;
  Locale: en-US (en_US.UTF-8); UI-Language: en-US, Calc: threaded
edit flag offensive delete link more
0

answered 2019-10-23 13:03:19 +0100

jbrid123 gravatar image

Thanks very much for your help. I understand now. It is much appreciated! John

edit flag offensive delete link more

Comments

Please do not post an answer on this site, if you actually don't answer a question (in this case your own) but commenting another users answer. Use add a comment for that purpose. And please click the check mark (✔) next to the answer, if the answer helped to fix your issue Thanks in advance.

Opaque gravatar imageOpaque ( 2019-10-23 13:06:46 +0100 )edit
0

answered 2019-10-23 02:51:48 +0100

pmfrench gravatar image

Tools menu,

click Options,

click the + in front of LibreOffice Calc in the left panel,

from the expanded list in the left panel click View,

in the Visual Aids section in the top right of the dialog box, click the down arrow at the right end of the Grid Lines box,

in the dropdown list, select Show,

click OK at the bottom of the dialog box.

edit flag offensive delete link more

Comments

The "grid lines" that showed in half the sheet were cell borders that were added through the Format/Cell dialog. They will print when the sheet is printed. What LibreOffice calls grid lines show on-screen only. If you want lines to print, you need to add borders to the cells.

pmfrench gravatar imagepmfrench ( 2019-10-23 02:54:04 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-10-23 00:01:37 +0100

Seen: 52 times

Last updated: Oct 23