Ask Your Question
0

Can font colour be changed in the latest Writer? [closed]

asked 2019-10-25 10:45:21 +0200

HerCorns gravatar image

updated 2020-08-08 10:29:53 +0200

Alex Kemp gravatar image

Hi Support Community,

I am using Libre Office Version: 6.3.2.2 on macOS Catalina.

I would like to change the text colour, but it only stays black.

What did I do? I selected the text and then clicked on the font icon to change the colour. In the previous versions, it changed the colour of the text, but now nothing happens. Is there a setting that I might be missing?

Please advise.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by HerCorns
close date 2019-10-28 01:46:18.210029

Comments

I can't duplicate this in ubuntu 18.04. Click on the font colour icon ('A' underlined in colour) to change to a pre-set colour. Click on the down arrow to select colour from the palette. Might your pre-set be black?

Pansmanser gravatar imagePansmanser ( 2019-10-25 17:12:25 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-10-26 12:35:36 +0200

keme gravatar image

updated 2019-10-26 12:43:36 +0200

Does the text also come out as black in preview and print? You may have the "show as black" options enabled.

  • Menu selection LibreOffice Writer - Preferences
  • Select branch LibreOffice - Accessibility
  • Untick the high contrast options.

You may have booted your computer in safe mode, where only basic device drivers (the bare necessities) are loaded. Proper screen software (retina driver in most cases) is not loaded, which makes color handling fail on some applications. This will also give occasional screen flicker on Apple displays. I have seen a few cases where the restart after upgrading to Catalina goes to safe mode. Reboot your computer.

edit flag offensive delete link more

Comments

Thanks Keme,

The reboot was not needed, but it is an excellent place to start for "windows" systems :) anyway I unselected the options one after the other and then restarted LibreOffice. The {Options for High Contrast Appearance} to uncheck is [ ] {Use automatic font colour for screen display}. After exiting LibreOffice and rerun it the font colour change is working as expected.

HerCorns gravatar imageHerCorns ( 2019-10-26 13:44:56 +0200 )edit

If you are in safe mode, a reboot is a good thing regardless of platform. That was the condition I suspected as a possible cause which a reboot would remedy.

Occasional reboot is useful in any case, because all systems develop "unwanted residue" over time. Sure, Windows goes stale faster than MacOS, but no system is immune to resource "leaks". Having a user base of 800+, mostly students and teachers, half of which are on MacOS, I have seen many a user revel at the responsiveness of a newly rebooted MacBook (only hibernating since they bought it, update "later", etc. etc.)

keme gravatar imagekeme ( 2019-10-27 02:39:21 +0200 )edit

Yes, I do agree with you that an occasional reboot or even shutdown is good for any computer type for the reasons you mentioned. I could not help myself to highlight the one operating system because I had to wait countless hours for it to reboot the system as technician :) I'm thankful to you for your fast analysis of the original issue. Then something totally unrelated. How do you add the grey boxes and red text for menu selections?

HerCorns gravatar imageHerCorns ( 2019-10-27 15:17:11 +0200 )edit

To make a button style text section, use the grave accent character to quote content. You can also use the "Preformatted text" tool icon, but if you use that on a full line the result is different.

keme gravatar imagekeme ( 2019-10-27 17:03:36 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2019-10-25 10:45:21 +0200

Seen: 100 times

Last updated: Oct 26 '19