We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
1

Why index entries change text to superscript ? [closed]

asked 2013-08-15 10:29:50 +0200

Andrzej gravatar image

When adding an index entry and changing the phrasing of the entry, a part of the text (one or many words) that follows is changed to superscript. Usual index entry (without modifying it) works fine.

Has anyone come across it ? Is there a solution ? Is it a bug ? I can manually change the text to normal but when saved and opened it comes back as superscript...

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-07 02:18:51.694418

Comments

I have the very same issue. When adding index entries, some of the text become superscript. If I put it back to normal, save the document and reopen it, it is superscript again. Libroffice 4.x windows, OpenOffice 4.x Mac, same behaviour. Looks like a bug even if there is hidden styles.

I'll try to clean things up by reseting direct styles on incriminated paragraphs.

Hope it'll go well, the document is 600 pages long ....

eskatos gravatar imageeskatos ( 2013-10-07 19:25:55 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-08-17 10:51:16 +0200

Andrzej gravatar image

OK, this is under Libre Office 4.1.0.4 running under Windows 7. But same problem on the Mac version.

I have some problems duplicating the effect on the test file, nevertheless the effect is as on the enclosed picture: I add a word to the alphabetical index (in this example Nora), changing the index entry to "Nora, Pierre". Afetr I save and reopen the file the text after the indexed word is superscript - and I have no idea how to fight it.

I can change it manually to "Normal" but it reappears...

image description

Here is the link to the odt file.

https://docs.google.com/file/d/0B3T1XcVZMqSzTDBDOThNdXB1dUk/edit?usp=sharing

edit flag offensive delete link more

Comments

Thanks for providing the file. I will update my answer above.

oweng gravatar imageoweng ( 2013-08-18 02:19:03 +0200 )edit
0

answered 2013-08-17 03:57:48 +0200

oweng gravatar image

updated 2013-08-18 02:30:23 +0200

What do you mean by "changing the phrasing of the entry"? Is this a reference to the Phonetics field? What file format (ODT, DOCX, etc.) are you using? Can you provide a link to an example file that displays this behaviour?

It would seem there is a problem with the styles in your document. The paragraph of text in your example file has an associated Appel note de bas de p. character style, which certainly has the superscript setting turned on. I would say this is likely causing the problem or is at least related. Certainly, if I highlight the paragraph of text and reapply the Default Style character style, the text all reverts to non-superscript. Similarly, if I delete the Appel note de bas de p. character style, the text all reverts to non-superscript.

Even with the character styles left as-is though, I still cannot replicate this effect here under GNU/Linux, so that may indicate it is a Windows-specific issue (with styles). I conducted tests with your file under v3.5.7.2 and v4.1.0.4 and the results were identical, regardless of what I highlighted or how I amended the Entry field when inserting an index entry.

edit flag offensive delete link more

Comments

It might be Windows, I'll recheck it in Mac and Linux. What happens if I change the style: nothing. It is certainly some bug with application of styles when mixed with an index entry, which is changed. Default index entry works fine.

Andrzej gravatar imageAndrzej ( 2013-08-18 08:08:10 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2013-08-15 10:29:50 +0200

Seen: 270 times

Last updated: Aug 18 '13