How to remove html span tags

asked 2019-10-31 03:56:31 +0100

kernix gravatar image

I write 90% of my WordPress blog posts using LibreOffice. I recently got a message to update the software which I did. I have been able to copy my post in the document into WordPress, erase all formatting then finish my post in WordPress. But now I'm getting a lot of tags in my blog post. How do IU prevent LibreOffice from adding those HTML taGS?

edit retag flag offensive close merge delete

Comments

LibreOffice just copies the content to the clipboard in a variety of formats (including HTML), trying to keep the formatting of the text. When you paste into browser (?), the browser/web page decides which of available formats to use, and the site decides what to do with that information later. It's not something LibreOffice controls.

You may try pasting as plain text (e.g. Chrome has it in its context menu) - if there's no such option in your browser, you may use an intermediate plain-text editor (like Notepad on Windows or gedit on Gnome): paste the data from LO there, then select and paste to the website.

Mike Kaganski gravatar imageMike Kaganski ( 2019-10-31 04:06:09 +0100 )edit

It wasn't doing it until I updated the version of LibreOffice so there is something different. I use Chrome, I paste into my WP editor, I select all and hit the clear formatting button. That would remove all the stickly span tags but not the span tags remain so it is LibreOffice.

kernix gravatar imagekernix ( 2019-10-31 12:29:57 +0100 )edit