Ask Your Question
0

Copy/Paste function in Writer does not work [closed]

asked 2013-08-18 22:09:55 +0200

Dennis1017 gravatar image

updated 2015-08-30 13:12:43 +0200

Alex Kemp gravatar image

I have been trying for some time now to Copy and Paste text in Writer. It simply does not work. I cannot tell if it is not copying to the clipboard, or if it is copying to the clipboard and not pasting.

I am running Windows 7 with all the current updates, and Libre Office version 4.0.4.2.

Anyone have any suggestions as to how I can get the Copy/Paste function to work?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 19:05:21.123197

Comments

One way I was able to copy&paste was saving the document as a docx document, open that in MS Word and copy from there. This worked reasonably but it screws up the levels of the heading. Alternatively copy&paste from LibreOffice into Word by right clicking in word and select "paste as text" but then you loose all formatting

NicoJ gravatar imageNicoJ ( 2014-04-28 13:35:17 +0200 )edit

This question is now a year old and it is not clear exactly which aspects of copy/paste are being referred to i.e., within LO, copy from LO to other application, copy from other application to LO. If this is not clarified I will close the question as invalid. Please edit it to be more specific (so that an effective answer can be determined). Thanks.

oweng gravatar imageoweng ( 2014-09-18 04:42:52 +0200 )edit

8 Answers

Sort by » oldest newest most voted
0

answered 2016-02-02 10:48:49 +0200

hderham gravatar image

I copy from a block of text in my email client (Outlook in Win 7) and open a new text document in Writer (5.04). When I paste, the block that pastes is the last block I copied from a writer document an hour ago. the most recently ^C block from Outlook is ignored, although it is in the clipboard. Pasting into MS Word works fine. What gives? Why is the clipboard over-ruled by LibreOffice Writer's own apparently proprietary clipboard?

edit flag offensive delete link more
0

answered 2013-08-19 02:03:53 +0200

Dennis1017 gravatar image

updated 2013-08-19 17:07:23 +0200

I have tried from both the Edit menu and using CTRL-C + CTRL-P. Oddly, I just tried it again, and it is working now. Not sure what is going on. Must be some combination of circumstances. Could indentations or some other formatting be interfering with the copy/paste function?

Update: it happened again. When I select Copy from the Edit menu, or use CTRL-C, the Paste function is grayed out and cannot be used. I cannot find a pattern to this issue yet.

The file is not an email attachment. It is an ODF file created in Libre Office Writer.

I generally don't like to install software Release Candidates, but in this case I did. So far, so good. I had noticed other quirks in 4.0 too. Hopefully, these issues have been resolved in 4.1. Thanks.

edit flag offensive delete link more
0

answered 2014-02-27 14:26:07 +0200

salem gravatar image

Had the same problem. No Libreoffice program would let me copy text into the clipboard. What you can do is start the windows task manager and end background processes one at a time, re-open the file with libreoffice and try to copy and paste a piece of text from it to notepad for example, and see after which ended process it starts working again. For me it was the process kleopatra.exe, which is an encryption software that was causing the problem. Cheers.

edit flag offensive delete link more
0

answered 2013-08-19 00:34:57 +0200

m.a.riosv gravatar image

updated 2013-08-19 18:40:59 +0200

From where you have open the file?, is it in edit mode?

edited.

I must insist, from where you have open the file?.
If the file is open attached to a email, it is open in read only mode, paste is forbidden. The same if the file was saved to open in read only mode.

Please verify if edit bottom is greyed.
image description

edit flag offensive delete link more
0

answered 2013-12-19 16:02:48 +0200

JimBobH gravatar image

I have often observed copy-and-paste problems with text and images. For example: 1. View a WWW page that has text and graphics in e.g. an "article", in any browser. 2. Drag your mouse cursor over the article body (avoiding sidebars etc.), selecting text and graphics together. 3. Control-C (Copy). 4. Open a New Writer document, position the typing cursor at the beginning, and Control-V (paste). 5. Voila' -- See exactly what you saw on the WWW page ... except no pictures/graphics. 6. Open a New Microsoft Word document in any format, position the typing cursor at the beginning, and Control-V (paste). 7. Voila' -- See exactly what you saw on the WWW page ... including pictures/graphics. Hm-m-m-m-m ...

Note: Writer behaves the same way on all versions of Linux, Mac OS, and Windows I have tried, in all the recent versions of Writer. There are rumors that there is a setting in Writer to make it stop behaving this stupidly (why would this be the default?) but nothing conclusive/official/helpful that I have been able to find so far.

edit flag offensive delete link more
0

answered 2014-09-18 02:16:00 +0200

It appears that, as of today, some bug has attacked the copy-paste function in LibreOffice. I am doing what I always do and nothing can be copied, then pasted in Writer. I can copy from somewhere else (Google Chrome) and paste it into Writer no problem, but nothing in Writer can be copied or pasted using the mouse right click, the menu, or Ctrl-C and V. WHAT IS GOING ON?

edit flag offensive delete link more
0

answered 2013-08-19 03:00:15 +0200

KD gravatar image

I recommend updating to 4.1, I find it far less buggier than the 4.0 version.

edit flag offensive delete link more
0

answered 2015-11-20 22:11:59 +0200

YOU SHOULD one-by-one, click on image>COPY IMAGE, and paste into DOCUMENT.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-08-18 22:09:55 +0200

Seen: 16,228 times

Last updated: Sep 18 '14