Ask Your Question
0

Correct method to install Libreoffice Base with Ubuntu 19.10

asked 2019-11-09 07:50:25 +0200

Dennis1234 gravatar image

What is the correct (recommended) method to install Libreoffice Base with Ubuntu 19.10, if you already have libreoffice installed.
What additional items need to be installed? ie types of java, backends etc.

D

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-11-09 17:45:58 +0200

gtomorrow gravatar image
edit flag offensive delete link more
0

answered 2019-11-09 18:17:38 +0200

Ratslinger gravatar image

Hello,

Your question is very general. For example you do not state what specific version of LO is installed nor where you got this version. This can be important. If you have the default distro version it may be an older version. Also it may not have Base installed. If so, you may want to consider installing the PPA version found here -> LO PPA. Remove older version first.

Now for additional installed items. This depends entirely upon which database you intend to use. If using Firebird embedded (already available with LO installed) there is nothing else to install. With this, however, if you want to access the Report Builder or use the Wizards to create forms or tables, you need to install Java. Java is also needed if you intend to use HSQLDB embedded (also included) as your database. For Java install see -> FAQ.

Now since Base is simply a front end to a database, you can use other databases such as PostgreSQL, MySQL, MariaDB, Firebird server and others. This will, in most cases, require installing additional items as well as the server itself for connection from Base to the Database server - JDBC or ODBC connectors for example.

For more information on connections (and the basics) see Chapter #2 - Creating a Database of the LO documentation found here -> LibreOffice Base Handbook

edit flag offensive delete link more

Comments

I'm sorry I forgot some information. I was trying to re-install LO 6.3.2.2, which was the latest version I had pre-installed on Ubuntu 19.10 after the upgrade. I had some issues and wanted to reinstall to see if that would correct it. I have no idea which database to use, firebird or HSQLDB. LO default or the one selected is HSQLDB. I had an issue with connections and had to install some items. I guess the real question is do I install from the distribution software center, or PPA or apt-get? Or other methods. The PPA seems fine, but I want a official release not nightly builds, is that the PPA fresh? Thanks

Dennis1234 gravatar imageDennis1234 ( 2019-11-10 06:12:59 +0200 )edit

Hello,

I personally would avoid the distro versions especially when dealing with Base. You typically need to add this in separately and often something is missing.

With the PPA version (Fresh or Still - NOT nightly builds) all is included (except as mentioned in answer - ie Java and other DB's) and the chosen version is updated when new releases are available. For the typical user of LO on Ubuntu the PPA version works well.

For many different reasons (mostly testing and development) I use the TDF (The Document Foundation) versions from the main LO page.

'apt-get' is typically not the way I would go.

Ratslinger gravatar imageRatslinger ( 2019-11-10 07:03:22 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-11-09 07:50:25 +0200

Seen: 279 times

Last updated: Nov 09 '19