Ask Your Question
0

Date Formatting not working [closed]

asked 2013-08-22 22:03:55 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am having trouble formating a column in a imported CSV file. The CSV file has the date construst as yyyy-mm-dd. Everything imports to the Date colum correctly. However whe n Itry to formate that column at a date in format d/m/yyyy, libreiffce does not recognize the change. When a highlight the cell, it appear that libreobbice insert a ' prior to the date, making the date unrecognizable. When I delete the character, the date shows up fine.

The apostrophe is not in the csv file and only happens in Libroffice. I tested with MSFT OFfice and Google sheets and the formatting occurs correctly.

Is this a bug or a setting that needs to be changed

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-07 03:52:37.286262

Comments

Please what is you LibreOffice version?, Seems to work right with Detect special numbers in 4.0.4, but not in 4.1.1

m.a.riosv gravatar imagem.a.riosv ( 2013-08-23 11:42:08 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-08-23 00:25:59 +0200

m.a.riosv gravatar image

When you import the CSV click on the head of the column with date and select the proper column type.

image description

edit flag offensive delete link more
0

answered 2013-08-23 00:28:45 +0200

w_whalley gravatar image

My vote is for a setting. If I open a csv file, the Text Import Dialog appears. Under the Other Options section there is a check box for Detect special numbers, and the Fields type defaults to Standard. When the Detect Special Numbers was unchecked, the column was imported as text. You can see this by selecting one of the "date" cells and choosing Format Cells (or Ctrl-1). The displayed type is Text.

Import with the Detect special numbers box checked and the column is imported as a date. You can alternatively set the import column type to Date (YMD).

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-08-22 22:03:55 +0200

Seen: 5,006 times

Last updated: Aug 23 '13