Ask Your Question
1

How do I prevent master document adding additional blank pages? [closed]

asked 2013-08-23 18:38:38 +0100

Jayjay gravatar image

I have checked all my sub documents and the formatting is fine and the same for each. When I combine these into one master document then I am seeing two or more additional blank pages being inserted. I have tried several fixes to try and overcome this problem but without success. Any suggestions, anyone?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 14:44:34.793062

2 Answers

Sort by » oldest newest most voted
1

answered 2013-08-24 07:02:44 +0100

oweng gravatar image

It is possible this is related to page definitions. Have you defined left and right page styles or are you using the First Page page style in you sub-documents? The First Page page style is purpose-designed to represent the single, first page (on the right) of an entire work, rather than the first page in each sub-document. Using this style in a sub-document, will force the page to commence on a right-hand page. Also, check your margins / page styles in your master and sub-documents to ensure they are identical.

edit flag offensive delete link more

Comments

I marked the answer +1 because of the "First Page" annotation; didn't knew anything about it. Also, take a look at that ask and be aware of that bug (if you want ;-)

guigonse gravatar imageguigonse ( 2013-11-17 01:15:30 +0100 )edit
0

answered 2014-01-15 22:56:22 +0100

guigonse gravatar image

updated 2014-01-15 22:57:43 +0100

I've been fighting with same problem for years, and I've read (and tested) a manual parcial solution: in the content.xml file you wil find auto-created styles (in my installation they're named "P1", "P2"...) with a

fo:break-befor="page"

attribute; if you delete all that attributes (editing with NOTEPAD.EXE, f.e.), re-compress de content.xml and open de modified document, you'll find all the page-breaks (and I mean ALL) deleted; you should insert them again where they where, and save the document.

Now, if you insert it in the master document... TADA! it will insert exactly next to the last text line over the cursor.

Docucraft! ;-)

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-08-23 18:38:38 +0100

Seen: 841 times

Last updated: Jan 15 '14