Ask Your Question

Hidden columns keep reappearing after I hide them.

asked 2019-11-16 10:11:21 +0200

updated 2019-11-16 11:12:46 +0200

Rows always stay hidden, but columns do not! I'm just trying to keep sheets user friendly, and for looks sake, so it's not a must, but odd it does such, how do I keep them hidden? Calc.ods Version, on windows 10

edit retag flag offensive close merge delete



Saved as .ods or .xls(x)? Also OS and LO version, please.

ajlittoz gravatar imageajlittoz ( 2019-11-16 10:16:23 +0200 )edit

Thanks @ajlittoz I put info above.

Mark McLean gravatar imageMark McLean ( 2019-11-16 11:16:03 +0200 )edit

Please add to your question a sample file having the issue.

m.a.riosv gravatar imagem.a.riosv ( 2019-11-16 16:01:38 +0200 )edit

Do columns stay hidden if you hide all columns with content in one go? (Select all columns in use, then Format - Columns - Hide.)

Do you have merged cells which become partially hidden when you hide the columns?

Have you tried grouping the columns to hide? Menu Data - Group and outline.

Grouping provides a simple interface to collapse/expand individual column/row groups or an entire grouping level.

keme gravatar imagekeme ( 2019-11-16 20:39:11 +0200 )edit

Now that you ask me such, it makes me think, All columns stay hidden, except those columns I do not have info in, those I do not use. How I hide them is, highlight one, then Ctrl+Shift+right arrow, then hide column. I’m not real sure when they open back up, but I think when I close the file and then reopen, but I'm not sure? Thanks for your help. As you can see, I built it to also share it! File t is to large to leave it here, so here is my link to it. To unlock sheets, just unlock, no password needed. Again, thanks.

Mark McLean gravatar imageMark McLean ( 2019-11-16 23:20:49 +0200 )edit

My above file,, needs no password to unlock, just click the tabs "Protect sheet".

Mark McLean gravatar imageMark McLean ( 2019-11-17 11:24:14 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2019-11-17 11:56:15 +0200

keme gravatar image

From your comments, I gather that you want to hide the "surplus rows/columns".

I suspect that the closest you can get to that is View - Page break preview.

edit flag offensive delete link more


Thanks, but it just made the page look smaller, and columns still shown. Odd, they allow rows to be kept hidden, but not columns. I guess there is a reason.

Mark McLean gravatar imageMark McLean ( 2019-11-17 12:12:12 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2019-11-16 10:11:21 +0200

Seen: 118 times

Last updated: Nov 17 '19