Ask Your Question
0

How can I hide the menu in a PDF?

asked 2019-11-20 18:42:53 +0100

rtorlas gravatar image

I just upgraded from Win7 to Win10. I don't remember the version of LibreOffice I had on Win7. I have tried both LO 6.2.8 and 6.3.3 on Win10. On Win7, from an odt in swriter, File -> Export As -> Export as PDF ... -> User Interface tab -> check Hide menubar would hide the menu bar would work. Now, it doesn't. Is there a work-around?

BTW, I've installed LO 6.2.8 on another Win7 system and can't get it to work either. However, I'm not dreaming as I have many PDFs with no menu bar.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-11-20 20:00:52 +0100

LibreTraining gravatar image

Most PDF viewers have a setting which can ignore the Hide Menu bar setting in a PDF.
My primary PDF viewer is set this way because I don't like people turning-off my menus.
Your PDF viewer may be set-up the same way.

I just did a test Export as PDF with Hide Menubar selected - from LO v6.3.3.2 x64 on Windows 10.
It worked correctly.
I opened the PDF in my PDF editor and checked the document settings - Hide Menu bar is selected.

Please check the checkmark at left if this answered your question.

.

edit flag offensive delete link more

Comments

I wasn't aware of that setting in the PDF viewer, but I found it and it was already set to allow the menu bar to be hidden. Let me try v6.3.3.2 to see if that works for me.

rtorlas gravatar imagertorlas ( 2019-11-20 20:39:01 +0100 )edit

That didn't work either. I noticed that all the modifications I had made to the PDF Options were still there after uninstalling v6.2.8 and installing v6.3.3.2. I then went to determine how to reset everything to default. I found that the settings are under %APPDATA%. I looked at my backup from Win7 and it has directories under Roaming\LibreOffice\4\user that do not appear on my Win10 PC. I guess Microsoft Backup/Restore decided to not restore that stuff. I'm working from home today, but will go into the office tomorrow and restore those settings and see what happens.

rtorlas gravatar imagertorlas ( 2019-11-20 21:21:32 +0100 )edit

I have recovered my %APPDATA%\Roaming\LibreOffice\4 directory and now the menus are hidden again. When I get home, I'll change the settings to the same and see if that works.

rtorlas gravatar imagertorlas ( 2019-11-21 14:15:19 +0100 )edit

I checked a virtual machine I have and it did not have %APPDATA%\Roaming\LibreOffice. I installed LO and it does hide the PDF menu bar with just that option checked. I guess the PC I installed LO on yesterday must have had LO installed before and the options messed up. We can close this due to operator error. Thanks for the help, LibreTraining. I'll go ahead and check your solution as a fresh installation does operate as expected.

rtorlas gravatar imagertorlas ( 2019-11-21 23:28:31 +0100 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-11-20 18:42:53 +0100

Seen: 22 times

Last updated: Nov 20