Ask Your Question
1

How to escape two columns trap?

asked 2013-08-28 09:59:57 +0200

L-user gravatar image

updated 2015-11-07 11:20:47 +0200

Alex Kemp gravatar image

In LibreOffice 4.0.5.2 Writer on Windows XP I created two columns and after that I am unable to escape outside of this two columns trap.

Details:
1. New Writer document.
2. Copy the following text and paste in document: "I would like to write text in two columns. So here is two column examples."
3. Select whole text e.g. CTRL+A.
4. Format | Columns.
5. In Columns input box change 1 to 2 and click on OK button.
Now text is formatted in two columns. But now we are in 'two columns trap'! Now suppose you would like to write some text bellow two columns formatting, but in ordinal one (one column) text layout. How to get outside of this "two column trap" into normal layout.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
2

answered 2013-08-30 09:38:56 +0200

oweng gravatar image

You can "escape" from the section created in the provided example (i.e., converting all content to 2-column layout) by placing the cursor at the end of the section and using ALT+ENTER.

edit flag offensive delete link more

Comments

1

Yeah, that's the key combo we're looking for. Of course, the same combination is the one to use to get "normal" text above the two-column bit as well. (And this is also true in the case of, e.g., a table at the top of a file that you you now want to go "above" -- which is a situation I end up in sometimes.) Thanks for this!

David gravatar imageDavid ( 2013-08-30 11:41:31 +0200 )edit

Hi, This doesn't seem to work in v5.0 . I want to put two images side by side.I created a section with two columns and inserted the images with captions in each column. I place the cursor after the second image/caption/column and hit ALT + ENTER.

Text entered now continues in the second column. How do I close that section and get back to the page style of a single column? This is driving me crazy!!

drjimbouk gravatar imagedrjimbouk ( 2015-10-30 21:00:16 +0200 )edit

Solution is to NOT select all!

jimbo1qaz gravatar imagejimbo1qaz ( 2015-11-20 10:02:10 +0200 )edit
1

This is most definitely still relevant It might be a newer version, and (Format | columns) no longer exists, but I was just in this trap. I pasted two column text. I created a new section (Section 2 a sub section of section 1) I was still dealing with two columns before and after section 2 (i.e. section 1) both section one and page layout didn't show two columns

Hitting ALT+ENTER at the end of the section broke me out of the two column trap.

pmheart6 gravatar imagepmheart6 ( 2018-06-13 22:46:10 +0200 )edit

@drjimbouk try creating a new section? In your example, the sections default layout is two columns -- this trap is if a section has an area of two columns within it when the section itself is listed as single column.

pmheart6 gravatar imagepmheart6 ( 2018-06-13 22:47:42 +0200 )edit

NOTE: My version is Version: 6.0.3.2 (x64) Build ID: 8f48d515416608e3a835360314dac7e47fd0b821

Also this may be and XML section vs LibreOffice section? hence alt-enter vs Insert | section or format | section (See next answer "no 2-column-trap" comment by oweng

pmheart6 gravatar imagepmheart6 ( 2018-06-13 22:52:20 +0200 )edit
1

answered 2013-08-28 16:52:31 +0200

ROSt52 gravatar image

updated 2013-08-28 17:44:39 +0200

L-user gravatar image

Be assured there is no 2-column-trap You need to create sections. A section for 2 columns followed by a section with 1 column (=Normal) or another section with 3 columns and so on....

Have a look at:
https://help.libreoffice.org/Writer/Inserting_Sections
https://help.libreoffice.org/Writer/Edit_Sections
https://help.libreoffice.org/Writer/Using_Sections

edit flag offensive delete link more

Comments

Thanks for help. I didn't know this can be solved using Sections (actually I never used sections before, despite using LibreOffice/OpenOffice for years).

L-user gravatar imageL-user ( 2013-08-28 17:46:19 +0200 )edit

The reason why this solves the dilemma is because columns are created using the <text:section> element and attributing the <style:columns> element as a property.

oweng gravatar imageoweng ( 2013-08-29 02:25:43 +0200 )edit

@oweng - thanks for the info on the technical background!

ROSt52 gravatar imageROSt52 ( 2013-08-29 07:41:41 +0200 )edit

A solution for me in LO5 if you have a section in two columns but want to go back to one column. I am working in an originally MS Word document so am not starting from scratch.:

Set all your text to 1 column Format->Columns. Highlight the part of your text which should be in two (or more) columns, then go to Format->Columns again and set the number of columns, making sure to apply to : Selection. Select OK.

Regards

TimC gravatar imageTimC ( 2016-03-08 04:10:37 +0200 )edit

Ahhhh xml code in the middle -- I think your section is different from the Libre office section .

pmheart6 gravatar imagepmheart6 ( 2018-06-13 22:48:53 +0200 )edit
0

answered 2013-08-28 17:47:57 +0200

L-user gravatar image

Actually I have found out another not-so-fancy solution. Just add some text to next line, I added single "x" character. So I am now sure I can always get out of two-columns-trap, just by clicking on x.

edit flag offensive delete link more

Comments

It might work always but it could get tricky. Good luck or decide to stay on the safe side. See @oweng's comment.

ROSt52 gravatar imageROSt52 ( 2013-08-29 07:43:02 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2013-08-28 09:59:57 +0200

Seen: 17,917 times

Last updated: Aug 30 '13