Ask Your Question
0

Macros and styles resetting occasionally

asked 2019-12-02 12:08:49 +0100

AstrantiFT gravatar image

updated 2019-12-02 16:56:19 +0100

Hi there,

I'm writing to ask about whether there are any solutions to a problem that myself and colleagues are facing. At times, created styles for headers and similar are resetting to plain text or changing without the use of the update style button.

Is this a version-specific issue potentially? If so, what is the most stable version for encountering minimal difficulties?

At present, my colleagues and I use V 6.1.5.2 Writer.

Edit: Documents are saved in .odt exclusively and the styles are typically applied with shortcuts/macros, however, this problem has occurred with manually selecting the style in paragraph/character.

We typically work from a template created in libreoffice, again in .odt format. From what I understand, this issue mostly occurs when editing older documents from previous LibreOffice versions - sometimes up to 1 year old. However, this is not exclusive, it has happened in recent documents also.

In terms of exact action being done when this issue occurs, it seems to happen predominantly when a proof reader is changing styles of certain headings from say 'Heading 3' to 'Heading 1' - and then occasionally the style will update Heading 3 to be Heading 1 - IE Heading 1 and 3 become identical.

Any assistance would be greatly appreciated. Thanks.

edit retag flag offensive close merge delete

Comments

Please edit your question (don't use an answer) to provide procedural details: are your documents saves in native format .odt or some other like .doc(x)? Are your documents based on a template? How are your headers/headings/paragraphs styled: exclusively with styles -- paragraph and character -- or also with "direct formatting", i.e. through toolbar buttons or shortcuts?

Can you characterize the circumstances after which format reset occurs?

ajlittoz gravatar imageajlittoz ( 2019-12-02 15:26:33 +0100 )edit

I have made amendments with as much information as possible. I hope this helps find a solution.

AstrantiFT gravatar imageAstrantiFT ( 2019-12-02 16:56:53 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-12-02 17:48:21 +0100

ebot gravatar image

updated 2019-12-02 17:52:38 +0100

As @ajlittoz already mentioned, direct formatting should be avoided, unless you know what you are doing.

According to your description, I suspect that corresponding Contaminated Sites issues are present in the documents or document templates.

To exclude direct formatting, you can edit your template (s) by selecting everything and choosing Format>Delete Direct Formatting from the menu.

Now format with your styles as you like and save your documents as a template again.

Another option would be to copy the entire text of a document / template into a text editor and copy it back to a new document to apply the styles.

I wish you success!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-12-02 12:08:49 +0100

Seen: 18 times

Last updated: Dec 02