Ask Your Question
0

Cannot apply filter in mail merge when data source is a Base query

asked 2019-12-07 18:12:53 +0100

gjkathome gravatar image

I am printing labels from Writer. If the data source is a Base table then I can apply a filter when I print the labels. If the data source is a Base query then the filter icon is greyed out. Am I missing something? I know I can get the effect I want by editing the query but I want this to be doable by the person doing the printing and they will not want to play with database queries.

edit retag flag offensive close merge delete

Comments

Please, always mention your environment work, operate system and LibreOffice version.

mauricio gravatar imagemauricio ( 2019-12-07 19:29:05 +0100 )edit

Hello,

Have just tested on Ubuntu 18.04 with LO v6.3.3.2 and Firebird embedded DB. The query was a simple select statement. Had no problem using the filter. It was not grayed out.

Along with previously mentioned needs please include the Query and database being used.

Another interesting thought. Can you filter the query in Base? If Run SQL command directly is enabled it appears filtering is disabled.

Ratslinger gravatar imageRatslinger ( 2019-12-08 05:35:26 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-12-08 07:17:48 +0100

Ratslinger gravatar image

Hello,

Continuing with the comment posted, if indeed Run SQL command directly is on in the Base query this is the cause of the filter not being available.

If this is the case, you can create a View based upon the SQL. Then using this view in Writer allows filtering even though the SQL is run directly.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-12-07 18:12:53 +0100

Seen: 69 times

Last updated: Dec 08 '19