Ask Your Question
1

Default UI font in Linux LO [closed]

asked 2013-09-01 18:40:43 +0100

Samjiyon gravatar image

updated 2016-02-18 17:04:15 +0100

Alex Kemp gravatar image

What is the very default font LO (v. 4.1) uses on Linux (Arch, x86)? I don't use KDE nor GNOME, my LO uses the basic "Win9x-like" GUI theme, so no GNOME/KDE font settings apply to it. And the option "Use system font in UI" is unchecked. How can I check which font LO actually uses as default for the GUI? In my case it's NOT Andale Sans UI, for sure. Can I change it somehow to whatever I like, e.g. via the LO's font substitution dialog?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-18 17:04:34.386072

2 Answers

Sort by » oldest newest most voted
0

answered 2014-01-19 17:22:16 +0100

I just came across the same issue in Kubuntu rather than Arch. I have noticed that when using the KDE DE in Ubuntu, Fedora, OpenSuse, etc, that font kerning can be an issue in LO. I recently installed infinality fonts and noticed a general improvement but also consistently poor font kerning solely in the LO UI. I unchecked "use system fonts" and it resolved the issue perfectly. However, I was also unsure which font was used in the LO interface. I did see mention of the Andale Sans UI font in the Arch Wiki (as you mentioned) but I can confirm that my installation was not using this as the default UI font. I simply made some comparisons between my system fonts and LO and my best guess is that it is the "Sans Serif" font used in the UI for linux LO installations. This also looked rather similar to "Arial" but open source fonts like "Liberation Sans", "DejaVu Sans", and "FreeSans" did not match nearly as closely.

edit flag offensive delete link more
0

answered 2014-01-20 10:57:40 +0100

oweng gravatar image

Under Crunchbang 11 x86_64 running LO v4.1.4.2 if I avoid using a system font for the UI (Tools > Options... > LibreOffice > View > User Interface section > uncheck Use system font for user interface) then DejaVu Sans (or the condensed variant) appears to be used. I am uncertain where this is set. It is not listed in:

/core/unotools/source/config/fontcfg.cxx

The fallback to Andale Sans UI appears to be indicated in (and I agree with the comment):

/core/vcl/source/window/window.cxx

DejaVu Sans is listed in the default font list for the registry (but so is Liberation Sans, which is also distributed with LO):

/core/officecfg/registry/data/org/openoffice/VCL.xcu

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-09-01 18:40:43 +0100

Seen: 2,076 times

Last updated: Jan 20 '14