Ask Your Question
0

Embed fonts when converting to pdf from the command line [closed]

asked 2013-09-02 22:28:33 +0200

pablo gravatar image

updated 2015-09-06 10:28:40 +0200

Alex Kemp gravatar image

Hi,

How can I tell LO to embed fonts when converting a doc to pdf from the command line? I'm using LO 3.5.7.2 on ubuntu 12.04

The command I'm using to convert docs to pdf is:

libreoffice --headless -–invisible --convert-to pdf:writer_pdf_Export --outdir out test.odf

The config option I need is explained here: Embed_standard_fonts

When I Set the option manually through the GUI the registrymodifications.xcu file gets the following item: /home/someuser/.config/libreoffice/3/user/registrymodifications.xcu

<item oor:path="/org.openoffice.Office.Common/Filter/PDF/Export"><prop oor:name="EmbedStandardFonts" oor:op="fuse"><value>true</value></prop></item>

Is there a global config file I can edit to add the above xml item? Do I need to add a config file manually to set this? I'm converting docs on a server with no GUI installed. The user has home dir under /var/lib/myuser/

On LibreOffice 4.2 all the fonts are embedded in the pdf but I need a fix for 3.5 Always embed 14 standard Postscript fonts in PDF

Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by manj_k
close date 2014-05-29 18:21:14.176256

1 Answer

Sort by » oldest newest most voted
1

answered 2014-05-22 09:48:14 +0200

pablo gravatar image

LibreOffice 4.2 is stable now so this issue doesn't matter any more.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-09-02 22:28:33 +0200

Seen: 2,295 times

Last updated: May 22 '14