Libreoffice Base: Block characters instead of strings in my tables (MONGO ODBC))

asked 2019-12-19 18:55:11 +0200

WieseckelRiley gravatar image

updated 2019-12-24 17:52:25 +0200

Database: MongoDB

ODBC: Progress DataDirect

Libreoffice: 5.0.6.2 86x64

OS: Linux (RHEL7)

I have created a connection between my Mongo Databases and libreoffice using Progress Datadirect's ODBC Driver. All in all it looks like its working great. I'm able to see my databases and my fields but when I open a table all of my text data is left as unreadable box shaped characters. I'm not sure if it has to do with encoding (Everything should be UTF-8) or maybe a character conversion error? When I plug my ODBC DSN into the driver's example application or into unixODBC Manager's testing utility (isql -v DataDirect) I am able to see my text data fine, so that makes me believe the problem is on Libreoffices end.

I have tried changing the charset and replacing fonts via Libreoffices tools and Database settings but nothing seems to make a diffrence. Its also very strange to me that all numbers and date values turn out fine as well as column names.

Any insight to the cause/solution to this issue would be greatly appreciated!

edit retag flag offensive close merge delete