Ask Your Question
0

function: (offset) questionable notation - is it really that way? [closed]

asked 2019-12-20 08:02:03 +0100

newbie-02 gravatar image

hi,

i just notet that 'OFFSET' has arguments (reference; rows; columns; height; width), that is something one can! work with, but it's not 'intuitive',

the notation for the name of a cell is: 'column first',

a simple minded user would expect the arguments in the same order, but it's 'rows first',

thus to check the functioning you can't do simple vector addition as we learned in school, but you have to 'transponse' the offset vector first ...

and plenty simple minded user will be trapped by writing wrong formulae ... :-(

imho there no chance to change this as it would break existing sheets, and most likely it's inherited from OO or 'excel compatibility', but i have two suggestions for former enhancements:

  • if there is ever any change: leave rows/columns as is, but change height/width to width/height, that would even more train users,

  • in naming of functions change 'read' to 'write' and vice versa, and 'store' to 'print' and vv, it reduces the amount of people which'll mess up your code,

[/humor off]

i have written this to make more users aware of its peculiarities and to help them solve problems from such cases more quickly

reg.

b.

edit retag flag offensive reopen merge delete

Closed for the following reason not a real question by ebot
close date 2019-12-20 09:12:26.033874

1 Answer

Sort by » oldest newest most voted
0

answered 2019-12-20 09:12:05 +0100

ebot gravatar image

[/ humor off]

Unfortunately, you are completely wrong with your concerns here.

You can submit suggestions for improvement on Bugzilla.

edit flag offensive delete link more

Comments

2

I would like to add that there are resons of the historical and of the pragmatrical class and also traditions in mathematics making the way it's done intuitive for many users.
Histrorical: The much clearer RC notation of references in spreadsheets that once was a standard, unfortunately discredited by its unhandy way to write relative references.
Mathematical: Element indices for matrices are always (?) in RC order.
Pragmatical: A change after decades of practice "as is" is not feasible. The ADDRESS() function uses "row first", too. So does the INDEX() function (Silly misleasing name! Also not changeable?).

Lupp gravatar imageLupp ( 2019-12-20 10:27:43 +0100 )edit

you are right, i already admittet that a change is nearly impossible, as other functions work the same it's a bigger problem on one hand, but easier to remember that there is! a problem on the other,

from math i'm used to (x,y) or (x,y,z) notations for functions, in that order, x horizontal, y vertikal, z orthogonal against sheet plane, thus columns first could be intuitive for mathematicians and people who had been to school ... i think it would be difficult to investigate who invented the different behaviour for spreadsheets and why ... i'll try to learn to live with it ...

@Lupp: for INDEX() - GETBYINDEX() or GETFROMRANGEBYINDEX() would have been a more intuitive name?

my question wasn't a proposal to change anything, just a question if i'm right, and a 'mine marker' for others ...

newbie-02 gravatar imagenewbie-02 ( 2019-12-20 13:55:44 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2019-12-20 08:02:03 +0100

Seen: 64 times

Last updated: Dec 20 '19