Ask Your Question
0

Heading / Subsequent Text formatting weird behavior [closed]

asked 2019-12-22 00:49:44 +0200

www.MKRD.info gravatar image

updated 2019-12-27 21:00:59 +0200

Hello, I believe that the fresh installation of LO Writer Version: 6.3.4.2 has some strange behavior: Starting with a document that is formatted as Text Body, I then insert some lines of text which are formatted as Headings (1, 2, etc). The OLD behavior was that pressing Enter starts a new paragraph underneath, resets the formatting from current Heading to Text Body, and then formats the text as Text Body. New (buggy) behavior is that paragraph underneath still gets called "Text Body" EXCEPT IT CARRIES FORMATTING OF THE HEADING ABOVE IT (text is larger, bold, etc). Selecting text and specifying it to be Text Body HAS NO EFFECT. The only way to "fix" the formatting that alleges it is "Text Body" is to keep selecting other formatting types (such as Heading 3), and keep trying to then apply "Text Body" formatting. What used to be a milli-second operation now takes me 20 seconds to resolve FOR EVERY HEADING THAT I INSERT.

Linux Mint 19.3 LO Writer Version: 6.3.4.2

[UPDATE] The template was somehow at fault, not LO. See accepted answer and generally suggested editing behavior:

  • Use built-in headings to apply "heading" information to a document.
  • To change how "headings" look, DO NOT edit their formatting directly, but edit their style instead.
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by www.MKRD.info
close date 2019-12-27 21:01:19.410567

Comments

Just to make sure you didn't inadvertently activate some formatting, do the following test:

  • create a heading paragraph
  • before typing content, Ctrl+M and also set character style (not paragraph style) Default Style
  • type the heading
  • hit Return to open a new Text Body paragraph
  • type some text; is it still formatted as a heading?

Give outcome of this text either as an edit to your question (clearly identified) or as a comment.

ajlittoz gravatar imageajlittoz ( 2019-12-22 07:50:06 +0200 )edit

@ajlittoz: Thank you for your comments! I will try them next time. I resorted to re-creating my template, clearing all formatting of affected files and re-applying headings to messed up files. Somehow, somewhere there is an issue hiding in my simple template. This issue is not occurring in other files. Turning ON formatting does not reveal the cause. I have never encountered a "broken" template like this, like it often happens in M$Word. I have NEVER seen an issue with LO barfing up formatting, and this issue just happened RIGHT AFTER an upgrade to 6.3.4.2. I guess stuff happens! I can only hope that the issue has been wiped out from my multiple files which have recently been typed up, all based on this buggy template.

www.MKRD.info gravatar imagewww.MKRD.info ( 2019-12-25 00:28:57 +0200 )edit

@ajlittoz: I am struggling with attachments here. Here is the broken template. Any ideas? I am not a 100% I am following your steps exactly, so you can try for yourself!:

http://www.mkrd.info/uploads/tmp/DOC%...

www.MKRD.info gravatar imagewww.MKRD.info ( 2019-12-25 00:58:38 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-12-25 08:49:03 +0200

ajlittoz gravatar image

I reopened your question in order to be able to give an answer.

6.3.4.2 is not at fault. I reproduced the "bug" in 6.2 and 4.1.

You probably edited your "template" applying changes as direct formatting on your headings instead of updating the paragraph style.

When you hit Return, a new paragraph is created with style set according to the Next Style property. Thus, you switch from Heading n to Text Body. However this switch involves only the paragraph style. If any attribute is set through a character style or direct formatting, they persist through the switch.

In your case, some (not all!) Heading 1 have received a "direct" bold command which will be forwarded to any paragraph created after it.

Fix is immediate:

  • select all text with Ctrl+A
  • clear direct formatting with Ctrl+M

Warning! This clears also all intentional direct formatting you could have made on your "template". Direct formatting must be avoided as completely as possible (though it can't be replaced in some special cases such as resetting page number or restarting list numbering) otherwise you bump into the kind of issue you experience. Work with styles (paragraph, character, page, frame, list): they give you full structured and organised control over your text appearance.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

@ajlittoz "You probably edited your "template" applying changes as direct formatting on your headings instead of updating the paragraph style. Direct formatting must be avoided as completely as possible."

I know enough to NOT apply direct formatting to headings, and to edit heading styles instead. I guess I am surprised as to how and when I was able to barf up such a simple template. This has not happened to me before, using Headings and such for a few years now of moderate use... Thank you for the additional comments, they should help others having the same issue and finding this article. I have reworded the article to remove claims of this being a bug.

www.MKRD.info gravatar imagewww.MKRD.info ( 2019-12-27 20:56:55 +0200 )edit

Question Tools

1 follower

Stats

Asked: 2019-12-22 00:49:44 +0200

Seen: 83 times

Last updated: Dec 27 '19