Locked File Error in Linux

asked 2019-12-27 21:00:46 +0100

jasona77 gravatar image

updated 2019-12-28 13:15:04 +0100

I am trying to open a Writer document in LibreOffice 6.3.3.2 on Kubuntu 19.10. When I do, I get the following error:

The lock file could not be created for exclusive access by LibreOffice, due to missing permission to create a lock file on that file location or lack of free disk space.

I have three laptops using this same setup and all of them give me the error when I try to open a document. I am using Google Drive using Rclone. I now know that the problem has something to do with Google Drive because I can open local files just fine. I have had this setup on other computers and it worked, I just do not understand why it is giving me a problem now and how to fix it. These are new installs to these laptops and this is the first time that I have tried to open a document. I reset my user profile but that did not fix the problem. Not sure what other information you need, but I will provide it for you.

edit retag flag offensive close merge delete

Comments

@jasona77, is the file found on your local system, on a network, or an external device? Does this happen with a single file or with all of them? Please, edit your question to add more information, such as file location, file type, etc.

RGB-es gravatar imageRGB-es ( 2019-12-27 23:03:17 +0100 )edit

This happens with all of my files, not just certain ones. I am using Google Drive using Rclone. I tested this and I can open all local files just fine, it is just the ones located on Google Drive. I have had this setup for a while with other computers and never had a problem until now. So now that we know the cause, how do we fix it? Everything is on Google Drive and this needs to work.

jasona77 gravatar imagejasona77 ( 2019-12-28 13:03:33 +0100 )edit

If you are using rclone mount - what is your setting of -vfs-cache-mode? On my test system I got it only working using: rclone mount --vfs-cache-mode full remote:/ /NET/GOOGLE/

Opaque gravatar imageOpaque ( 2019-12-28 16:28:42 +0100 )edit

At one time, on other computers I used “rclone --vfs-cache-mode writes mount drive: ~/google” but I actually put this as a startup script. I tried that this time but “--vfs-cache-mode” no longer works. So I actually started using “rclone-browser.” I just mount if from within the GUI. I am not sure what commands it is using to mount.

jasona77 gravatar imagejasona77 ( 2019-12-28 20:03:43 +0100 )edit

I just mount if from within the GUI

From within which GUI?

I have three laptops using this same setup

and now your last comment generates a gut feeling that this is not the case.

--vfs-cache-mode no longer works

I just tried exactly that during my test. So please tell output of rclone version (mine states:

rclone v1.47.0
- os/arch: linux/amd64
- go version: go1.11.9

)

Finally, I can't see that it isn't suported on Ubuntu:

user@system:> rclone mount --help | awk "/--vfs-cache-mode CacheMode/"
      --vfs-cache-mode CacheMode               Cache mode off|minimal|writes|full (default off)
Opaque gravatar imageOpaque ( 2019-12-29 01:31:20 +0100 )edit

From within which GUI? Rclone Browser

I have three laptops using this same setup and now your last comment generates a gut feeling that this is not the case

Those three laptops are the same make and model and are running the same software and versions.

The output of rclone version is:

rclone v1.47.0
os/arch: linux/amd64
go version: go1.12.9

I also got the same output for rclone mount --help | awk "/--vfs-cache-mode CacheMode/" Then it hit me, the last time I tried --vfs-cache-mode and it did not work, I was using Linux Mint on a different computer than the three in this instance. I assumed that since Linux Mint was based off of Ubuntu, that it would not work on Kubuntu and that is why I was using rclone browser. So I unmounted the drive in rclone browser and closed it out. Then I ran ...(more)

jasona77 gravatar imagejasona77 ( 2019-12-29 12:04:53 +0100 )edit