Ask Your Question
0

how to get indents and margins working properly? [closed]

asked 2013-09-08 07:46:53 +0200

bernie bernardo bernstein gravatar image

On MS Word when you wanted the second and subsequent lines in a paragraph to be indented, you'd just ctrl-click the bottom triangle in the ruler up the top of the document and drag it to the right to the position you wanted the indent to be. Ctrl-click on it in libre and it allows you to drag the bottom triangle to the right, but when you let go of the mouse, it moves it even further to the right and ALSO brings in the top triangle (i.e. the margin of the paragraph) and brings in the end triangle for the right margin. Any ideas how I make it act rationally?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-07 23:53:42.432218

2 Answers

Sort by » oldest newest most voted
2

answered 2013-09-08 15:01:42 +0200

David gravatar image

updated 2013-09-08 15:04:05 +0200

Any ideas how I make it act rationally?

:) "Migrating" isn't always easy, is it? LibO Writer and MS Word 2003 look sufficiently similar that one is lulled into a false sense of security, thinking that the programs are, in fact, "the same". But they're not, of course, and (as I've learned myself) moving to LibO is easier if one learns its strengths rather than wanting it to be directly a 1:1 FOSS version of MS Word.

Having said that, for me (LibO 4.0.4.2 on Linux Mint 13), CTRL-click-drag on the bottom triangle works exactly as you expect it to, and I can't coax it into the behaviour you describe. I think. If you deliberately follow this sequence:

  1. Hold down CTRL;
  2. THEN click lower triangle, drag to desired location;
  3. then release click;
  4. and ONLY then release CTRL ...

then the hanging indent is produced as expected. If, however, the click-hold on the triangle comes first, then the CTRL key doesn't have any effect, and both triangles move together. I can't reproduce your "...it moves it even further to the right..." behaviour, though.

If that doesn't work, it would be good to know your version of LibO, and what operating system you're using, so perhaps you could add that in. (This information is good to include any time you're asking for help, in fact.)

However, my own preferred mode of working (now) is to use styles. I keep the "styles" panel docked (F11). Instead of doing clicking-dragging: if I want an indent paragraph, I just double-click the "Hanging Indent" paragraph style to apply that style to the current paragraph. Right-click on the style and select Modify to set the parameters of the style (how much "hang", etc.).

I use "styles" now almost to the exclusion of the "local" formatting from the top toolbar (which was/is my normal mode for MS Word). Note that styles operate at character and page level, as well as paragraph, and that there are convenient ways of accessing the "Style" panel if you want it mostly hidden, but available for quick use.

FWIW. YMMV. etc.

edit flag offensive delete link more
0

answered 2013-09-09 02:36:55 +0200

bernie bernardo bernstein gravatar image

Thanks for the reply. I was getting strange behaviour at one point (after opening a .docx file and saving it as .odt) with manual tab stops not working either. I had to recreate my docx file from new as purely an odt file, and the tabs started working. But the margins and the triangles still don't work. I ended up using the paragraph styles to make it work.

I'm on Windows 7 64 bit. I'm using LIbre office 4.1.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-09-08 07:46:53 +0200

Seen: 3,395 times

Last updated: Sep 09 '13