Ask Your Question
0

Importing Word documents changes page format. How to fix?

asked 2020-01-09 10:14:47 +0200

edcdeee gravatar image

updated 2020-07-22 14:40:24 +0200

Alex Kemp gravatar image

I have imported numerous Word documents from my old computer, in which the paper size in Page format was set to A4. When opening these documents in LibreOffice 6.3 I find that the paper size (both in Page format and First Page format) has been changed from A4 to Letter. As my printer is set to print A4 pages when I try to print a page with Letter format the printer does not print but asks me to load paper of that size. I do not know what process caused this change in paper size. I can change the paper size manually, but there are many documents involved. Is there some way to change the paper size from Letter to A4 automatically in all my stored documents?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-01-09 10:21:35 +0200

gabix gravatar image

First, a remark: are you sure that your documents were really in A4? Normally, LibreOffice correctly determines the paper size when importing Word documents.

I'd think about the following procedure:

  1. Use the built-in Document converter wizard to convert all Word documents to ODT.
  2. Create a template with the desired page style(s) (and other as necessary) settings.
  3. Then use the TemplateChange extension to apply the template to the converted documents.
edit flag offensive delete link more

Comments

I tried your suggestion. Unfortunately TemplateChange extension produced corrupt ODT documents.

edcdeee gravatar imageedcdeee ( 2020-01-10 04:05:55 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-01-09 10:14:47 +0200

Seen: 74 times

Last updated: Jan 09 '20