Ask Your Question
0

Why are v and T followed by a space?

asked 2020-01-14 20:13:26 +0100

HunkyDork gravatar image

updated 2020-01-15 00:43:49 +0100

In Calc the letter v but not the letter V is always followed by a space: ex: "Viv ian" instead of Vivian. How do I correct that? Also the letter T is followed by a space but not the letter t ex: t ext instead of text. The version is "LibreOffice_6.3.3_Win_x64". That does not happen in an old .xlsx file made with "Words" many years ago, if I enter new text in that file, it is normal. The problem is there if I save the file as .ods or .xlsx My OS is win10 Font is default Arial The problem does not occur with Lucida or Time New Roman If possible, how can I change the default font? The problem persists across keyboards, US English or Canadian Multilingual Standard. This problem is not new I noticed it a long time ago and moved to Words. I now want to use LibreOffice. Thanks for help HD

edit retag flag offensive close merge delete

Comments

I can't reproduce this behaviour with LO 6.3.3.2.0 in Fedora Linux 31. It sounds to me like a font-specific issue.

Edit your question to provide needed technical details (OS, LO version, font used).

Si vous préférez, vous pouvez aussi poser la même question dans la section francophone du site https://ask.libreoffice.org/fr/questions

ajlittoz gravatar imageajlittoz ( 2020-01-14 20:23:21 +0100 )edit

I use Win10 the font is Arial which is the default font on that app. Lucida and Time new Roman don't do that. How do I change the default font?

HunkyDork gravatar imageHunkyDork ( 2020-01-14 23:10:18 +0100 )edit

The LO version is the latest update

HunkyDork gravatar imageHunkyDork ( 2020-01-14 23:11:18 +0100 )edit

The windows version is also the last update and the problem is the same on "canadian multilingual standard" and with "English United State US keyboard"

HunkyDork gravatar imageHunkyDork ( 2020-01-14 23:20:21 +0100 )edit

@HunkyDork: "latest update" maybe relevant at the time of writing of your question but surely won't be in 6 months when a new version has been released. The same goes for the OS. I'm pretty sure that the "latest update" on my Linux box is not the same as yours. So, it is much better to cite accurately the versions numbers.

ajlittoz gravatar imageajlittoz ( 2020-01-15 11:51:53 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-01-15 01:12:42 +0100

jamess gravatar image

Hi you pose an interesting question. I will propose that it has to do with what is called "kerning"

This goes back to when a page of text was made by placing physical blocks of wood ( with a letter on each block ) and when 'lead' type was used similarly, each letter being on a "block of lead".

The letters were placed upside down into a box, the letters themselves being backwards, ink was applied, a piece of paper was laid on the pieces of wood or metal ( holding the letters ) and the "positive' of the page was produced which had the letters being able to be viewed correctly.

Since each block or wood, or lead, had its own size, the letters on the finished page looked ok when the page was printed, in terms of "the spacing of the letters".

To separate one sentence from another, not only was there a "period" or an "exclamation mark' or whatever there had to be an "extra" piece of JUST THE METAL BLOCK inserted to have the sentences have a "space" between them.

So, as to the W and the T. The reason for it, I assume is similar to the above with the "empty" piece of wood or lead.

The problem is that digital letters are NOT ON A BLOCK OF WOOD.

So, enter "kerning".

The letter W, in many instanced, appears to be an upside down "M" , depending on the font.

A capitalized "T" ...."spreads out" over the "bottom of the letter.

A capitalized "L" ....."spreads out" under the "right side " of the "top" of the captial L.

So, if a capital W was, for whatever reason, directly next to a capitalized M they would 'squeezed up next to each other and for a, visually weird "WM" squeezed to each other so the "extra space" is to seperate things like that and same with such as an "L" and a "T".

the software naturally takes into account these situations so that things appear to be spaced correctly visually.

I provide a link to a discussion here about "kerning" and how it can be "turned off".

https://wiki.openoffice.org/wiki/Docu...

This is all just my humble opinion, if others differ please so comment. jamess

edit flag offensive delete link more

Comments

Thank you for that answer but you see, the problem happens only in new documents and only with Arial font. Arial font is the default, I need to change the default

HunkyDork gravatar imageHunkyDork ( 2020-01-15 02:13:29 +0100 )edit

@HunkyDork: to change the default font (provided you didn't change Default Style paragraph style), go to Tools>Options, LibreOffice Writer>Basic Fonts (Western). If you messed up Default Style, modify it again (though best method is to reset it to factory settings and paly with the options).

Oops! My answer is valid for Writer only! I apologise. In calc, try to change Default style. I don't know if the update is kept in the user profile.

ajlittoz gravatar imageajlittoz ( 2020-01-15 11:55:19 +0100 )edit

Doesn't get me very far but I appreciate the consideration HD

HunkyDork gravatar imageHunkyDork ( 2020-01-15 15:19:31 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-01-14 20:13:26 +0100

Seen: 44 times

Last updated: 2 days ago