Ask Your Question
0

Autocomplete date in Writer does not enter the current date, it enters the date Writer was started

asked 2020-01-17 00:26:16 +0100

let gravatar image

I’m using LibreOffice Version: 6.0.7.3 Build ID: 1:6.0.7-0ubuntu0.18.04.1 under Ubuntu 18.04

When using Writer I often enter a date in the format “YYYY-MM-DD”.

When I Enter “202” AutoCorrect (I’m guessing) gives me the option of entering a date, right now “202” becomes “2020-01-16” today's date.

Except I found out this isn’t today’s date, it’s the date Writer was started.

I checked the AutoCorrect options and can’t find any for dates.

Is there some way to have AutoCorrect insert the current date?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2020-01-17 08:46:35 +0100

Yes you are right. It is because the call to LoadDefaultCalendar in QuickHelpData::FillStrArr doesn't do anything if current calendar is already initialized previously (LoadDefaultCalendar needs to be able to force re-initialization).

Please file a bug about it.

edit flag offensive delete link more

Comments

Thank you This answers my question

let gravatar imagelet ( 2020-01-17 21:30:28 +0100 )edit

tdf#130066

... now fixed.

Mike Kaganski gravatar imageMike Kaganski ( 2020-01-18 10:30:24 +0100 )edit
0

answered 2020-01-17 08:11:27 +0100

ajlittoz gravatar image

I've never experienced such a behaviour, but I usually disable AutoCorrect.

The recommended way of inserting dates is through fields because you can control both the format and the update.

Date fields come in two flavours: fixed (insertion date will not be changed in the future) and "not-fixed" (date is changed to current when document is printed or updated).

The detailed field dialog offers many formatting options. And if you're satisfied with the built-in ones, you can craft your own.

The same goes for time. You can check with it that current time & date is the one at time of insertion not when Writer was started. However, since it seems your behaviour is somehow related to AutoCorrect, it may be that some entry was captured when Writer was started and used afterwards.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-01-17 00:26:16 +0100

Seen: 70 times

Last updated: Jan 17 '20