We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question
0

Getting started with base, Q for more recent version.

asked 2020-01-24 21:27:15 +0200

Carex gravatar image

I'm just starting and using the adobe version of "Chapter 8: Getting started with Base". I am Setting up my first form, adding first subform after having created a relationship as instructed. In the dialog box "Decide if you want to set up a subform" with "Add Subform" checked the radio button for "Subform based on existing relation" is not available. I presume because the relationship has not been created correctly. All my screens when building the relationship match those shown in the manual.
What do I have to do different? I would be happy to search archived answers if provide a key to finding them:)

edit retag flag offensive close merge delete

Comments

Hello,

It is always preferable to include your OS, the specific version of LO you are using and for Base the database being used (ie: Firebird embedded, HSQLDB embedded, etc.). It would also help if you posted a sample of your Base file. Edit your question and using the paperclip icon on the toolbar (upper left in question) attach.

Ratslinger gravatar imageRatslinger ( 2020-01-24 21:51:39 +0200 )edit

Using version 6.2. Firebird imbeded (the default) on Windows 10. Upload of file may have to wait until early tomorrow morning. I don't think I have the bandwidth to upload it now.

Carex gravatar imageCarex ( 2020-01-24 22:43:52 +0200 )edit

File not needed. Answer should resolve your situation.

Ratslinger gravatar imageRatslinger ( 2020-01-24 23:08:06 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-01-24 23:05:46 +0200

Ratslinger gravatar image

Hello,

There are a couple of points to answer the question.

First Base documentation is in need of updating especially in regard to using Firebird embedded database.

Second is the version of LO you are using (6.2 is still not specific). In newer versions Firebird embedded is not the default. This has now reverted to HSQLDB embedded. Firebird embedded is still available and usable but still has items to be corrected. The version you have still has the relation/subform issue. This is fixed in later releases ( I am using v6.3.4.2 on Ubuntu 18.04). You can still do this but need to select Subform based on manual selection of fields and on subsequent screens select the relation manually.

edit flag offensive delete link more

Comments

Many thanks. I take that my first efforts since dBase4 and the first release of Access should use HSQLDB, this may be the most valuable advise! (Firebird embedded may not have been the default but was the first of two choices and words are less intimidating than strings of letters). v6.2.8.2 took a bit of searching (for me). Thanks again!

Carex gravatar imageCarex ( 2020-01-24 23:53:34 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-01-24 21:27:15 +0200

Seen: 47 times

Last updated: Jan 24 '20