Ask Your Question
1

[Solved] Open ods or odt files from a smb share throws damaged file error

asked 2013-09-23 16:06:16 +0100

Joepp gravatar image

updated 2015-09-09 01:22:12 +0100

Alex Kemp gravatar image

Hi there,

Opening xls, csv files with LO is not a problem. Opening ods, odt files from .gvfs mount point also open up fine. The problem is that Nautilus will follow the symlink inside the .gvfs folder to transform it back to smb://server and LO complains that the file is corrupted. (It is not, if I copy the file to home folder it will open up fine). It I choose to repair the file, a LO Math opens up an empty file. If I choose not to repair the file, LO gets stuck in a loop asking all the time if I want to repair it.

I did some reading and came up with different opinions wheter the problem is file locking, some gvfs-fuse problem and other non working solutions.

Currently I'm using LO 4.1.1 on a Xubuntu 12.04

I rely on this smb share, I can't change it to NFS or whatever. Any help appreciated.

Thanks,

Joe

edit retag flag offensive close merge delete

Comments

I've been having the same problems. I'm using Ubuntu 13.04, with LO 4.1.1. and it will not open any word, calc or base file over a GVFS share mount, I have to copy it to my desktop and open it from there.
From another computer, Ubuntu 13.04 and LO 4.0.0.3, I am able to open files but occasionally get corrupt files - sometimes they are not really corrupt (opens from the computer holding the files) but other times the file does become truly corrupted and non-recoverable.
No solutions yet,

Libre Lyrae gravatar imageLibre Lyrae ( 2013-09-23 16:44:11 +0100 )edit

4 Answers

Sort by » oldest newest most voted
3

answered 2013-09-24 02:41:27 +0100

oweng gravatar image

updated 2016-02-12 01:34:32 +0100

GVFS has long has problems under LO. I remember reading on the Dev mailing list why this is but I can't remember the cause now. There are numerous questions on this forum about problems accessing files on Samba shares. I provide a summary of some of them here. Related bugs include:

  • fdo#56544, lock files on Samba shares Resolved for v5.0.6, v5.1.2, and v5.2.0. Refer related thread
  • fdo#58052, ucpgvfs1.uno.so fails to load
  • fdo#59424, I/O Error while opening file from WebDAV over GVFS from Nautilus
  • fdo#67527, LO can't open files over SMB - wants to repair!

It has been suggested here that the last bug contains a workaround in comment #15, and an easy way to apply this is:

sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/share/applications/libreoffice-*

Obviously the path used in the example should be changed according to your install location.

EDIT: Comment #59 in the last bug provides further information, which I will quote here:

The repair dialog is an Ubuntu 12.04 specific bug, related to glib package. See https://launchpad.net/bugs/1214352

The problem with KDE is another problem, mostly related to missing packages:

  • For the build from distro repositories, you should also install 'gvfs' and 'gvfs-smb' packages for Fedora, or 'gvfs', 'gvfs-backends', 'libreoffice-gnome' for Ubuntu.

  • For the build from libreoffice.org, you should also install 'gnome-vfs2', 'gnome-vfs2-smb', 'ORBit2' for Fedora, or 'libgnomevfs2-0', 'libgnomevfs2-extra', 'liborbit2'. You should also export 'OOO_FORCE_DESKTOP=gnome', otherwise it won't work.

edit flag offensive delete link more

Comments

Awesome!

Thank you so much! (And: the path matches my system Xubuntu 12.04 - great)

Joepp gravatar imageJoepp ( 2013-09-24 12:07:08 +0100 )edit

Thank you so much!!!

rik-shaw gravatar imagerik-shaw ( 2013-12-05 23:02:39 +0100 )edit

After installing LibreOffice 4.2.1 (or 4.1.5) on Ubuntu 12.04, put in the terminal:

sudo sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' /usr/share/applications/libreoffice*

gegon69 gravatar imagegegon69 ( 2014-03-05 22:18:33 +0100 )edit

Worked for me too! On Ubuntu 14.04 and LO 4.3.3

harlequin gravatar imageharlequin ( 2014-11-10 11:05:55 +0100 )edit

When opening files from nautilus then, I get the following error: "error when accessing /run/user/1001/gvfs/dav:host=…,ssl=true,prefix=…"

Andy gravatar imageAndy ( 2015-02-06 17:47:50 +0100 )edit

GVFS has generally been troubling, usually causing high CPU usage for mostly nothing.

rautamiekka gravatar imagerautamiekka ( 2016-02-12 02:25:51 +0100 )edit

Ubuntu 18.04, Minimal Install, Ubuntu Software add LibreOffice Calc, requires manual 'sudo apt install libreoffice-gnome'.

rcpa0 gravatar imagercpa0 ( 2018-05-04 19:20:31 +0100 )edit
0

answered 2014-04-09 15:47:11 +0100

Jeremy Andrews gravatar image

same problem

edit flag offensive delete link more
0

answered 2013-09-24 12:12:56 +0100

Joepp gravatar image

Thank you oweng! I'm unsure where to head to just to say "me too" in order to get this bug fixed. Bug 67527 seems to match. Any advice?

Thanks again.

edit flag offensive delete link more

Comments

The usual place is in the bug itself, but in honesty there is already a lot of interest in this bug, so unless you have something constructive to contribute I would suggest giving it a miss. You can however add yourself to the CC list in the bug so you are kept informed of any developments. It appears to be a regression in the LO v4.1 series so will likely be fixed before long.

oweng gravatar imageoweng ( 2013-09-24 12:32:53 +0100 )edit

Understood. Thanks again!

Joepp gravatar imageJoepp ( 2013-09-25 10:22:16 +0100 )edit

NOT AN ANSWER ! DELETE !

rautamiekka gravatar imagerautamiekka ( 2016-02-13 00:20:07 +0100 )edit
0

answered 2019-04-17 15:28:34 +0100

Instale desde repositorio devuan libreoffice-gnome y funciona i'm install from repos devuan libreoffice-gnome, now works

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2013-09-23 16:06:16 +0100

Seen: 16,139 times

Last updated: Apr 17