Ask Your Question
0

How to set the default spell check language?

asked 2020-03-07 18:49:50 +0200

BrolleJr gravatar image

I'd like to write documents in Swedish, but every time I create a new document I have to set the spell checker to Swedish from the English default. Is there any way to change this, so that it's checking against Swedish from the start?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2020-03-07 19:21:53 +0200

ajlittoz gravatar image

updated 2020-03-07 20:08:17 +0200

There are many ways to do that. It depends on how frequently you switch languages.

  • Tools>Options, Language Settings>Languages, section Default Languages for Documents

    This setting will be saved in your user profile if you don't chack For the current document only and will apply to all future documents.

  • Change paragraph style Default Style, Fonts tab`, Language menu in the default template

    Default Style paragraph style is intended to set all default attributes for a document and should never be used to format text. Use the other styles.

    Again, this will apply to all new documents, i.e. to write documents in other languages, you must change the attribute again.

  • Create a template from the default template where you change the language as shown in the previous tip

    Save this template as Swedish (or any meaningful name for you). You can have as many custom template as you like, e.g. one per language. To create a new document, instead of File>New>Text Document, do File>New>Templates to select the appropriate template (language).

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

In case you need clarification, edit your question (not an answer which is reserved for solutions) or comment the relevant answer.

edit flag offensive delete link more
0

answered 2020-03-21 13:39:25 +0200

Ermano gravatar image

I'm afraid it (still) doesn't work. When you look up the subject you find many entries about it which confirm that it doesn't or that it is unstable. In my case I've essentially given up on it and try to improve my own spelling skills. I have version: 6.0.7.3 on Ubuntu 18.04.4 LTS

Going the way as described in your post it always takes the system language (German in my case) - whatever I do. Neither: Tools-> Language -> For all text -> English Nor: Tools>Options, Language Settings>Languages (putting everything ! to English) and leaving "Ignore input language" checked + rebooting each time changes anything to this behaviour.

BTW. When I put Libreoffice in "half screen mode" and switched between it and my Chrome window (on the right half of the screen) to write this text, the whole command bar (File ....Help) on top gets unresponsive after using it for only once. I had to restart Libreoffice 4 times to get it going again in order to write this text.

I hate to admit it, but since I regularly have to write text in 4 or 5 different languages it has become essentially useless to me and I only use it now since I'm locked in at home (Covid-19) where I have no access to my Work computer.

edit flag offensive delete link more

Comments

1

This is no answer to the initial post and I nearly neglected it, believing just another suggestion was given. You should have updated your question (thus refreshing it and sending it at top of unanswered ones). So, please, do it. This will give you back the possibility to answer (which you lost with this "answer").

I'm routinely writing in 3 languages and have no problem with the above "recipes". Consequently, I need a very accurate description of your work procedure. Even if it sound silly or obvious: have you installed the dictionaries for the target languages? Are you using templates? Do you prefer to manually switch language with every new document (may be preferred if the languages are equally likely)?

Concerning the responsiveness issue, it has nothing to do with languages and be a question of its own. I kind of remember it has already been asked and that ...(more)

ajlittoz gravatar imageajlittoz ( 2020-03-21 14:07:45 +0200 )edit

routinely writing in 3 languages

Me too. Plus 5 or 6 other ones occasionally. Since OOo 3.0 no problem with multilingual spellcheck. No problem at all.

gabix gravatar imagegabix ( 2020-03-21 14:46:04 +0200 )edit

I add that I write also multilingual documents. This means I must dynamically switch paragraph or sequence-of -words language. This is more complicated than single-language documents and it works perfectly well once you have carefully crafted your styles.

ajlittoz gravatar imageajlittoz ( 2020-03-21 15:43:18 +0200 )edit

@ajlittoz Thanks for your quick reply, so fast that I didn't even expect it, thus the delay... I could dig into the problem a bit more deeply. A) I removed the Ubuntu pre-installed version 6.0.7.3 and installed the most recent 6.4.2.2. Checking it in LO-Writer: It worked (This also answers your question about the installed language packs)

In LO-Impress however the situation is a bit more complicated: I work on a PowerPoint MS-office 2016 Standard document (from work) originally written on a Win-10 computer with an English OS and a German keyboard. I have to leave the original .ppt format since I have to give the presentation on a computer with MS-PPT (only). My computer is (as told) 18.04.4 LTS but opposite to what I wrote before, the OS is in English and the keyboard (again) in German. I use a ...(more)

Ermano gravatar imageErmano ( 2020-03-23 10:59:23 +0200 )edit

I carry on with a second post (due to the limited #of chars). Now I "sort of got it to run". In LO-Impress, doing: Tools->Language->for all text ->More.
Setting 1) "Local settings" to French (for example) and 2) "Default Languages for Documents" equally to "French" still didn't solve the problem but 3) again: Tools->Language->for all text ->French will finally force it to French. As far as I could see I have to do step 1) ("Local settings" to make it appear as a chooseable in step 3), the " Tools->Language->for all text" menu. Now I haven't checked all the ramifications of this problem, if I find out more I will post it here of course. Regards, and thanx again: Hermann

Ermano gravatar imageErmano ( 2020-03-23 11:17:42 +0200 )edit

Ah, by the way: I did of course realize that the freezing of the toolbar is not connected to the language settings, I just mentioned it because this pesky behaviour kept on creeping up over and over again as I wrote the text (since I had to swap between my browser and LO-Impress. As told, I had to restart LO several times to find out the different steps I took (in LO-Impress) and than convert them to text here in my post. This problem still persist in version 6.4.2.2.

Ermano gravatar imageErmano ( 2020-03-23 11:23:07 +0200 )edit

Keyboard: the magic of Linux, at least under GNOME and KDE desktop, is that you have nice keyboard utilities. You can then easily customise keyboard handling to fit your needs. Whatever keyboard you have (US_English, xx_French, yy_German, zz_Klingon), you can define key combinations to generate your favourite characters., E.g. you want to write German with an international (US) keyboard. You can assign ä, ö and ü to Alt Gr+A, o or u and the same in uppercase with Alt Gr+Shift+… on the A, O and U keys, the same for ß on S if not already there. Alternately, you can define " as a dead key to compose with the following keystroke (a kind of accent). Possibilities are limitless. If you don't want to lose existing combinations, you can use other "modifiers" such as Alt or the left/right "Windows" keys.

ajlittoz gravatar imageajlittoz ( 2020-03-23 13:58:09 +0200 )edit

Ha, this time I'm faster... I know, but it it still nice to have the characters visible on your individual keys of the keyboard. I also did it using the Unicode in the past which works in most of the MS Office applications. At work I have to move rather often from an English to a French and to a German keyboard which can get quickly confusing and in this case the visual check is handy to have. Actually the only reason why I mentioned the keyboard(s), is that this was the only link I could see to my language problem: LO-Impress always tried to do the spelling check in German although I had everything(!) in (Tools->Language->for all text ->More) set to English + English OS (linux) on my home computer and English Win10 on my Work computer (from where the file originated from). So I'm still a ...(more)

Ermano gravatar imageErmano ( 2020-03-23 14:10:43 +0200 )edit

I am not as fluent in Impress as in Writer. The style system is less developed there. However, you still have the possibility to tell in the Font tab the target language for the style.

My advice would then be to create ad hoc styles for your paragraph (one for German, one for French and one for English). Unfortunately, this will likely be kept from one session to the next only if the file is saved as .odp, not .ppt(x) because I don't think M$ implemented styles (as is the case with Word which does not support character, page and "list" styles). Consequently, my advice is save your files as .odp while you work on them and export as .ppt(x) only at the end when you're done. Warning! I experienced compatibility problems with bullet characters.

The problem remains for "alien" words in paragraph (e.g. an ...(more)

ajlittoz gravatar imageajlittoz ( 2020-03-23 14:22:06 +0200 )edit

It is indeed the compatibility issue which made me stick to the M$ (I like that !) -format in my present work. I'm not really trained in styles, more of a superficial user, but sure something I should dig obviously. For the "embedded" words: no problem, I try to keep their number low anyway.

Ermano gravatar imageErmano ( 2020-03-23 14:45:16 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-03-07 18:49:50 +0200

Seen: 112 times

Last updated: Mar 21