Ask Your Question
0

6.4 gtk2 display problem

asked 2020-03-12 10:54:15 +0200

peebee gravatar image

updated 2020-07-10 10:25:36 +0200

Alex Kemp gravatar image

Running 32-bit: Version: 6.4.1.2 Build ID: SlackBuild for 6.4.1 by Eric Hameleers CPU threads: 8; OS: Linux 5.5; UI render: default; VCL: x11; Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB Calc: threaded

When I updated from 6.3 to 6.4 the display changed drastically becoming very old-fashioned with small fonts and small icons. Would like to know why this has happened and what I should do to return the display to the 6.3 version. A screenshot of a calc screen is attached.

image description

edit retag flag offensive close merge delete

Comments

Why is this question gtk2 labled? Are you forcing the UI to use the VCL gtk2 backend instead of gtk3? If so, that might be the problem. I notice VCL: x11 in your about text, that usually is VCL: gtk3 on Linux.

erAck gravatar imageerAck ( 2020-03-12 23:41:45 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-03-13 20:40:13 +0200

peebee gravatar image

Hi its GTK2 related because my system uses GTK2.

I had also noted the VCL: X11 - this is a change from 6.3 when it used to say VCL: GTK2

Has GTK2 support been dropped from 6.4??

edit flag offensive delete link more

Comments

1

Has GTK2 support been dropped from 6.4??

Short answer: yes.

RGB-es gravatar imageRGB-es ( 2020-03-13 22:50:45 +0200 )edit

Even if I install GTK+3 I still get small icons, small fonts, chunky old-fashioned window controls and VCL:X11

How can I restore the 6.3 look and feel?

peebee gravatar imagepeebee ( 2020-03-15 15:43:15 +0200 )edit
0

answered 2020-03-27 21:31:03 +0200

jmux gravatar image

LibreOffice can be build with various backends on Unix. You can check for the supported backends by looking for libvclplug_* libraries in the "program" directory of your LibreOffice installation, like:

  • libvclplug_genlo.so
  • libvclplug_gtk3_kde5lo.so
  • libvclplug_gtk3lo.so
  • libvclplug_kf5lo.so
  • libvclplug_qt5lo.so

LibreOffice tries to autodetect the desktop and select a matching backend. You can override the detection, by starting LibreOffice from the teminal with "SAL_USE_VCLPLUGIN=gtk3 soffice". This just works, if LibreOffice was compiled with the backend, the library is installed and the dependencies of the backend library are installed (check ldd of that library to be sure).

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-03-12 10:54:15 +0200

Seen: 186 times

Last updated: Mar 27 '20