Ask Your Question
0

Is there a nice solution to having thicker table lines?

asked 2012-05-03 14:09:22 +0200

wryun gravatar image

When I print standard LibreOffice tables the cell borders are barely visible as the lines are too fine. Now, I assume I could do some default template magic and have all new tables have wider lines, but is there some way I can fix this problem for any document I print?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2012-05-03 16:23:11 +0200

salisburyk gravatar image

Yes, you are on the right track. For writer anyway, you need to change the default template (or create a new template for your specific project needs). Look at the help here; http://help.libreoffice.org/Writer/Changing_the_Default_Template

...you can try changing it by using your current page style as well; http://help.libreoffice.org/Writer/Creating_a_Page_Style_Based_on_the_Current_Page

There's also a LibreOffice Extension for table border enhancements in Writer and Calc; http://extensions.libreoffice.org/extension-center/borderliner

LibreOffice Help for Table Border Changes http://help.libreoffice.org/Common/Defining_Borders_for_Tables_and_Table_Cells

edit flag offensive delete link more

Comments

Yes, I understand I can change the template, but surely this only applies for new documents? What about existing documents (as in question)? Ideally, I suppose, I want some override for this particular printer to say "don't do lines that fine". I suppose it's a problem with the printer driver...

wryun gravatar imagewryun ( 2012-05-04 00:13:45 +0200 )edit
1

Sorry, I misunderstood the question. AFAIK, there is not automated way to do this currently. There's a GSOC proposal to make Writer Table styles easier...http://wiki.documentfoundation.org/Development/Gsoc/Ideas#Implement_table_styles

salisburyk gravatar imagesalisburyk ( 2012-05-04 18:27:14 +0200 )edit

Thanks for your help! Sorry I was unclear.

wryun gravatar imagewryun ( 2012-05-06 04:42:22 +0200 )edit

@wryun, Please feel free to file an enhancement bug as well.

qubit gravatar imagequbit ( 2013-02-17 05:45:47 +0200 )edit
0

answered 2015-03-20 00:36:58 +0200

I know it's been two years since this quesiton was asked, so you may have moved onto another program or figured this out for yourself by now, but just in case you haven't, I just found a solution to this problem.

Highlight/select the entire table and then in the bottom left corner where the table menu is, there's a drop down menu called "Borders, add lines; SHIFT to add and remove" (NOT the Line Style drop down). Select the bottom right option/image (I'd provide a screencap, but apparently I have to earn points before I can upload images, so sorry about that), which only shows up if you've highlighted the entire table, so be sure to do that. This option makes it so that ALL LINES in your table are considered border lines. So then you can right click on the table, select "Table..." to bring up Table Options, and under Borders you can change the width of the border line. Because your table is treating all lines as borders it thickens the entire grid instead of just the outer border lines. FEW. Hope that made sense.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-05-03 14:09:22 +0200

Seen: 3,349 times

Last updated: Mar 20 '15