Ask Your Question
0

LibreOffice 6.4 interface is too laggy

asked 2020-03-31 22:31:18 +0200

rafaelhlima gravatar image

updated 2020-04-01 01:50:10 +0200

There is an issue with LibreOffice that annoys me a lot... Its interface is too laggy!

On Writer, every time I start a new typing stream, letters take a few miliseconds to appear on screen. O Calc, the same happens when I type numbers on a spreadsheet. The same happens on Impress, when I select a textbox or drawing element, it always takes some type for the interface to respond. It makes the user experience not fluid and is a serious problem with my adopting LO.

This never happens on MS Office, which is very fluid accross all applications. Interface response is immediate.

I am running LO mainly on a Windows 10 machine, on a Ryzen 7 3700X and 16Gb of RAM. I believe this sort of issue should not happen on my machine. Also, the laggy interface problem happens on two laptops I have, both running Windows 10, with i5 and i7 processors and 8GB of RAM.

I am also a Linux user and experienced low interface performance using LO on Ubuntu 19.10 too.

I have tried disabling/enabling OpenCL and Java, but I got no noticeable improvement. As much as I am looking forward to migrating to LO, this issue is a major obstacle to me.

What am I doing wrong? Or is this just the way LO is? Can anyone help me?

UPDATE: I have just ran LO on Kubuntu and it worked perfectly, as expected. No lags and the fonts were smoother than on Windows. But why is it that LO is so laggy on Windows (and on Gnome)??

edit retag flag offensive close merge delete

Comments

I can't seem to replicate the problem you are having. I'm using Libre Writer with Windows 10 and everything seems normal. No evidence of laggy performance.

BAret gravatar imageBAret ( 2020-04-01 02:25:19 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-04-22 06:39:43 +0200

gyht gravatar image

I have the same problem. Have made the adjustments but no difference. Running v. 6.3.3.2 on Mac OS 10.13.6.

edit flag offensive delete link more
0

answered 2020-04-01 05:33:40 +0200

blashrkh gravatar image

updated 2020-04-01 05:35:15 +0200

I had this problem the other day.

  • Try switching off OpenCL and restart libreoffice. Make sure OpenCL is switched off Tools->Options->LibreOffice->OpenCL
  • Try setting your windows pagefile size to zero. start->run->sysdm.cpl Advanced->Settings->Advanced tab and select change button then set to zero page file size. You will need to restart windows.
edit flag offensive delete link more

Comments

Would changing the page file size to zero affect the performance of my system overall?

rafaelhlima gravatar imagerafaelhlima ( 2020-04-01 16:10:02 +0200 )edit

Paging is the effective transfer of working RAM memory to disk if you have too many applications open in order to "hibernate" applications with allocated memory but not actively being used. Given disk is a slow memory storage you want to minimise how many apps you have open.

Switch off the page / set the page file to zero as a temporary test to see if access to free RAM may be an issue. Even if you have RAM available it is worth doing to see if it also has an impact on general windows performance.

blashrkh gravatar imageblashrkh ( 2020-04-03 03:38:20 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-03-31 22:31:18 +0200

Seen: 205 times

Last updated: Apr 22