We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

Base ODF report - Odd colums [SOLVED]

asked 2020-04-01 16:14:59 +0200

mgl gravatar image

updated 2020-08-02 02:34:01 +0200

Alex Kemp gravatar image


I start from a former release of a report, under ODF format and had to update it. The former report did show properly 25 columns. This report has : 1°) a page header, including a long label as report title with 25 labels as column headers underneath the long label, 2°) a detail section that contains the 25 fields.

I relocated the 22nd column in the 4th place and added-up a new one as 7th place. All labels have the same width and x-position as their related columns.

The result is not easily legible as there is an extra blank cell between the 6th and the 7th column and from then, every label is displayed in a two-cells fused cell. For the data fields, no extra cell between the 6th and the 7th column but every data is displayed in a two-cells fused cell. So the column header and the data are not aligned under each other and when I try to copy and paste the data in a neatly formatted sheet with conditional formatting, the data do not fit in the right place.

As a sketch is better than a long speach, you'll find the report in here

Thanks in advance for your help. Michel

EDIT April 3rd, 2020 Bug open in Bugzilla : https://bugs.documentfoundation.org/s... Password removed.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2020-04-03 18:20:49 +0200

mgl gravatar image

The solution was to up-grade LibreOffice. Up-grade to Version : Build ID : 1:6.4.2-0ubuntu0.18.04.3 solved this issue, thanks to bugzilla support.

Many thanks to Ratslinger too.

edit flag offensive delete link more



Glad your problem is solved, but with mine:

Version: Build ID: 4e471d8c02c9c90f512f7f9ead8875b57fcb1ec3 CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: gtk3; Locale: en-US (en_US.UTF-8); UI-Language: en-US Calc: threaded

this has continued to be an issue. Have been using that version all along and still see many problems in that area.

Ratslinger gravatar imageRatslinger ( 2020-04-03 18:52:34 +0200 )edit

answered 2020-04-01 22:28:16 +0200

Ratslinger gravatar image


This appears to be a bug. Your sample is not visible because a password is required.

However, you can take any existing report then add another field and the extra space is generated. Only method I can vision thus far is creating as a new report. Once something is move the problem arises.

You should file as a bug report here -> Bugzilla

edit flag offensive delete link more


Also of note the problem actually exists in the text documents too - tables are greatly messed up.

Ratslinger gravatar imageRatslinger ( 2020-04-01 22:47:09 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2020-04-01 16:14:59 +0200

Seen: 92 times

Last updated: Apr 03 '20