Ask Your Question
0

Remove newer version [closed]

asked 2013-10-06 02:26:18 +0100

spartanhooah gravatar image

I currently have version 4.0.2.2. LibreOffice tells me that there's a newer version available (4.0.5), so I downloaded it and tried to install it. However, when I run the .msi package, it tells me that "A newer version of LibreOffice 4.0.5.2 was found. To install an older version, the newer version needs to be removed first." The only thing that can happen next is aborting the installation.

What? I have an older version installed, not a newer one! I'd rather not have to uninstall and reinstall LO every time there's an update, so what can I do to fix this?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by manj_k
close date 2013-12-17 20:53:48.657941

2 Answers

Sort by » oldest newest most voted
1

answered 2013-10-06 17:39:14 +0100

L-user gravatar image

updated 2013-10-06 18:16:16 +0100

This is strange. Your version was 4.0.2.2 and when you try to installed 4.0.5.x it recognized your current installation as 4.0.5.2, so it gives you an info if you would like to downgrade! then you need to uninstall previous version before downgrading. This is logical. Downgrading can be a problem, so uninstall is required. Don't know why your current installation was recognized incorrectly (maybe some kind of bug or you really already had 4.0.5.2 in the first place).

In general on Windows if you install 4.0.x and are upgrading to newer version then you don't need to uninstall LibreOffice first. See this web page for more info: https://www.libreoffice.org/get-help/installation/windows/ where is a statement:

You do not have to de-install any previously-installed version of LibreOffice. If you do have an existing installation of LibreOffice, all your preferences will be preserved and that old installation will simply be overwritten.
If I remember correctly the only exception was LibreOffice 3.5.x to 3.5.y migration where uninstall was required due to a bug in LibreOffice. So this was exception that was solved few years back.

A word about 4.1.x - this is latest stable version, but can be more buggy then currently extra stable 4.0.x. So if you are enterprice user I would suggest to use 4.0.x, if not then you can install 4.1.x and if some problems appears report them at bug tracker.

edit flag offensive delete link more
0

answered 2013-10-06 11:45:00 +0100

nighthome gravatar image

I'm not on M$ Windows so can't say for sure. But from what I know this is fixed in LO 4.1.x and upward. So best to download again from http://www.libreoffice.org/download and install that. From that on things should be smoother. Not sure if you have to uninstall first, but don't think so (at least on OS X that's not required, on Windows maybe so).

edit flag offensive delete link more

Comments

1

Yup, that worked fine. No idea why I was being directed to the wrong download site, and this still doesn't address the underlying issue, but ah well. (Also, "M$"? Really?)

spartanhooah gravatar imagespartanhooah ( 2013-10-06 14:40:35 +0100 )edit

Getting OT, but - "Also, "M$"? Really?" - but with news like this ( http://bgr.com/2013/08/21/microsoft-windows-8-nsa-back-door/ ) Windows isn't really an OS, that should be used or supported. That's just one of many arguments speaking against windows. Usability being another. But as I said, that's getting OT.

nighthome gravatar imagenighthome ( 2013-10-06 15:10:42 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2013-10-06 02:26:18 +0100

Seen: 845 times

Last updated: Oct 06 '13