Ask Your Question
0

Minimize macro security warning

asked 2020-04-04 01:29:15 +0200

Tran Quang Luu gravatar image

Every time I open a Calc worksheet which contains macros, a warning dialog appears. The problem is while I'm busy with other applications this warning also appeared and interrupted my workflow. Is there a way to make it appear only when I come back to LibreOffice?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2020-04-04 12:25:48 +0200

jmux gravatar image

Generally this is not implemented in any way in LibreOffice. And I'm not aware of any application implementing this. But if LibreOffice doesn't have the focus, it shouldn't steal it. This is normally handled by the operating system, not an application itself.

There was a change in the code, which brings windows to the front, in LibreOffice 6.4.2 on Windows. That might help in your situation, if you are using Windows. Generally focus steal handling / prevention is a tricky business. In Linux various DEs / window managers have their own setting to handle this more or less successful.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-04-04 01:29:15 +0200

Seen: 45 times

Last updated: Apr 04 '20