Ask Your Question
0

why are some subdocument tables truncated in the master document? [closed]

asked 2013-10-09 11:29:47 +0200

nick keighley gravatar image

updated 2020-07-29 00:10:36 +0200

Alex Kemp gravatar image

The tables appear ok in ODT files but when imported into ODM documents they are truncated. I suspect some setting in my ODM document as other people aren't having trouble with the same document

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-12 14:56:25.777130

Comments

I'm having the same problem: tables look perfect in the ODT, but when inserted in the Master Document (ODM) they get totally missformated (rows get huge, or microscopic height).

I've checked formats both in ODT and ODM, but doesn't seems to affects. By the way, I've made answer 1 changes, but nothing seems to work...

Working in LO 4.1.2.3. BTW, it takes a long time to import the ODT in the ODM in every DOC upgrade; it's a long table... ;-)

guigonse gravatar imageguigonse ( 2013-10-30 09:22:25 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2013-10-30 09:49:08 +0200

guigonse gravatar image

Sorry, I've continued trying options, and clashed to (my provisional) solution: - In the sub-document (ODT file) get sure all the table text has the same style assigned (in my doc, "Table Contents"). - In the Master Doc (ODM file) open Format/Style and Formatting (or press F11), right-click your table text style, which should be the same as in the ODM (remember, in my ODM and ODT files, "Table Contents"), go to tab "Indents & Spacing" and UNCHECK "Register-true" option. - Verify that the rest of the style in the Master keeps as similar as possible to the sub-document. Et voilà!! :-D

It seems that LibreOffice, in general, is gettint more and more fragile with formats, as options grow.

Hope it helps you (it did to me ;-).

edit flag offensive delete link more

Comments

I have marked your answer up, as the register true setting can produce unexpected results especially if differing line heights and text sizes are involved. This may, as you indicate, help someone. Without specific detail or an example document (from the reporter) I can't reproduce the problem posed by this question under GNU/Linux running v4.1.2.2. Thanks for the suggestion.

oweng gravatar imageoweng ( 2013-11-01 01:16:53 +0200 )edit
0

answered 2013-10-13 12:16:24 +0200

oweng gravatar image

When you state:

... when imported into ODM documents

... do you mean when you open the ODM as opposed to the individual ODTs? I am not sure why this would be happening but the first thing I would check is the table settings. In particular ensure the table can break over a page Table > Table Properties... > Text Flow tab > ensure "Allow table to split across tables and columns" is checked. Perhaps also uncheck "Keep with next paragraph" if this is checked.

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2013-10-09 11:29:47 +0200

Seen: 139 times

Last updated: Oct 30 '13