Ask Your Question
0

How do I make a GIF file in Libre Draw?

asked 2020-04-17 03:42:44 +0200

BAret gravatar image

I would like to make a GIF file to demonstrate the way my program is functioning when making a drawing of a polygon. I have tried to describe it but it would be better to have a file showing its behaviour. In brief, the polygon can be drawn but as soon as another function is called, the polygon disappears without being recorded.

edit retag flag offensive close merge delete

Comments

Closed for the following reason duplicate question

... and the original question (possibly with a useful answer that could help someone who comes here looking for solution) is ...?

Mike Kaganski gravatar imageMike Kaganski ( 2020-04-17 08:52:55 +0200 )edit

@ebot: sorry, I don't see how that YouTube video on trapezoid manipulation helps creating a screencast GIF. The text below that video also does not mention how was it created. OP didn't ask for others' videos, but for way to create own.

Mike Kaganski gravatar imageMike Kaganski ( 2020-04-17 09:53:04 +0200 )edit

That's why it says "Can this help?" Maybe the OP can decide whether it can help?

ebot gravatar imageebot ( 2020-04-17 13:16:09 +0200 )edit

Mike Kaganski hit the nail on the head. The video about finding the parallel sides of a trapezoid confirms the fact that a GIF can be created. My problem is that I don't know how to do it. I will continue my search for the answer. Thanks for the interest.

BAret gravatar imageBAret ( 2020-04-17 21:08:42 +0200 )edit

In brief, the polygon can be drawn but as soon as another function is called, the polygon disappears without being recorded.

Can you please explain to me what you record with or how you do it.

ebot gravatar imageebot ( 2020-04-17 22:30:30 +0200 )edit

Sorry ebot, I missed your question. I am not recording. I see the shape being drawn. To close, I press Alt + Dbl click. The first polygon appears to close but the cursor remains the same polygon cursor instead of changing back to an arrow. I can draw another polygon with the same result, but eventually, if I move to another function, say draw an ellipse, immediately all of the polygons I drew are erased from the screen. They are not recorded by the program because on refresh, they never appear again.

I am in the process of finding a workaround. One method is to draw an octagon, convert to a polygon, then move the eight points to wherever I want them. It is quite limiting as you will appreciate.

BAret gravatar imageBAret ( 2020-04-19 03:53:46 +0200 )edit

@BAret: without knowing your OS, no way to suggest you something. Personally I use screentogif.com on Windows.

Wrt your problem - what you describe looks like not using doubleclick, but a single click. Doubleclicking would complete and end current multiline. You may also doubleclick after you alt-clicked, to end it.

Mike Kaganski gravatar imageMike Kaganski ( 2020-04-22 15:23:22 +0200 )edit

Thanks Mike, I will check into screentogif.com. I can assure you, I am double clicking at the end of the polygon. On March 5 of this year, I was able to draw polygons with OpenOffice by just double clicking. Now, both OpenOffice and LibreOffice require Alt + dbl click to terminate, but neither program stores the polygon data. I am thinking I must have corrupted something in my computer, but that is not an easy problem to solve.

If I am able to create the GIF, I will post it here. Otherwise, I will simply forget about it as I have found ways to live without it.

BAret gravatar imageBAret ( 2020-04-22 16:43:19 +0200 )edit

Okay, I have the GIF file now, but I don't know how to post it here. Here is a link: https://res.cloudinary.com/engineerin...

That seems to work okay. After drawing the second polygon, I went to load a rectangle and both polygons vanished into thin air. That is typical now.

Incidentally, I really mean to thank you for the screentogif program. It works like a charm.

BAret gravatar imageBAret ( 2020-04-22 23:09:56 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2020-04-25 04:58:15 +0200

BAret gravatar image

I am able to form the polygons, but as soon as I try to load a rectangle, the polygons vanish. See GIF below:

I don't know the answer, but I suspect my computer has been corrupted in some way.

C:\fakepath\PolygonProblem (2).gif

edit flag offensive delete link more

Comments

ebot, Started the program in Safe Mode, but problem is exactly the same as before. Same result in OpenOffice which used to work until March 5, 2020. I uninstalled OpenOffice and installed an earlier version...same problem. It's a puzzle.

I won't be available to correspond until some time tomorrow, but if you post a comment, I will answer your post as soon as I can.

BAret gravatar imageBAret ( 2020-04-25 07:28:29 +0200 )edit
0

answered 2020-04-25 06:33:44 +0200

ebot gravatar image

Try to start once with the Safe Mode.

If the error is no longer there, you should reset your user profile.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-04-17 03:42:44 +0200

Seen: 37 times

Last updated: Apr 25