Ask Your Question
2

Weird SVG bug in Libreoffice 4.1.2.3 [closed]

asked 2013-10-14 20:23:17 +0200

Daniel Ruf gravatar image

updated 2015-08-28 09:38:14 +0200

Alex Kemp gravatar image

I am using the original SVG file from http://en.wikipedia.org/wiki/File:Google_Chrome_icon_(2011).svg

When I insert it into the odt document it looks normal. But when I export it as PDF file, it looks like this:

SVG bug

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-12 15:45:02.605947

2 Answers

Sort by » oldest newest most voted
2

answered 2013-10-15 01:19:28 +0200

Pedro gravatar image

updated 2013-10-15 01:21:37 +0200

I can confirm the bug both under 4.1.3.1 and 4.0.5.2 when loaded in the Windows version (under XP x86 Pro SP3).

If you go back to version 3.6.7.2 or 3.5.7.2 you get an accurate result but it is the same jagged bitmap it shows before creating the PDF :)

image description

However if you get the latest Alpha from the 4.2 branch, you get something completely different :D

image description

It would be nice if you reported this bug to the developers at
https://bugs.freedesktop.org/enter_bug.cgi?product=LibreOffice
or at
https://www.libreoffice.org/get-help/bug/

edit flag offensive delete link more

Comments

could you or someone else do this? Because I have currently not an account for this and don't know what to write there to describe the problem. But what I do not understand: why are there all these regressions in the latest Libre Office version? 3.6 seems to be stable and has the best SVG support but 4.1/2 seems very unstable, buggy ... =(

Daniel Ruf gravatar imageDaniel Ruf ( 2013-10-15 16:18:53 +0200 )edit
1

No problem, I will report the bug and link it here. As for regressions: this is the price to pay for time based releases. As new features are added (e.g. vector quality is FAR superior in 4.1 and 4.2, without raster jaggies) some bugs are also added. Because new releases don't wait for all bugs to be fixed (otherwise LO would still be in 3.4.4 :) ) some regressions occur. It is sometimes frustrating but in the long run it seems to be a better option.

Pedro gravatar imagePedro ( 2013-10-15 21:05:16 +0200 )edit

can you provide the link to the bug report so I can take a look at the issue and when it will be fixed? This would be really great.

Daniel Ruf gravatar imageDaniel Ruf ( 2013-10-18 17:03:23 +0200 )edit

@Daniel Ruf, I haven't had the time to report it. Hopefully I will do it during the weekend. In any case reporting the bug just guarantees that it is known, not that anyone will fix it (and certainly no prevision on how long it will take...)

Pedro gravatar imagePedro ( 2013-10-18 17:09:31 +0200 )edit
2
Pedro gravatar imagePedro ( 2013-10-31 01:06:43 +0200 )edit
0

answered 2013-10-31 09:25:08 +0200

skibbbi gravatar image

I acknowledge the error. Calc -> Insert picture from file. In Calc looks good but when I export to PDF is exactly the same mistake as the author of the thread.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-10-14 20:23:17 +0200

Seen: 615 times

Last updated: Oct 31 '13