Ask Your Question
1

Error creating new document:templates already exist [closed]

asked 2012-02-20 18:34:42 +0200

leon244 gravatar image

updated 2015-10-16 02:05:36 +0200

Alex Kemp gravatar image

Using 3.5 under Linux. When I try to open a new document via the menu (File->New->Templates and Documents) I get the above error and my templates folder does not open. I can only access them via Files->Templates->Edit. Under options the templates Path is present. This appears to be a bug. Anyone else having this problem and any work arounds?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-16 02:06:45.832862

10 Answers

Sort by » oldest newest most voted
1

answered 2012-03-11 23:02:12 +0200

MannDTP gravatar image

updated 2012-03-11 23:38:18 +0200

I was having this exact issue here under Ubunutu 11.04 with LibreOffice 3.5. I read the other "solutions" and instead of just doing them, I did some testing.

Here is the correct way to fix this issue, without having to wipe out the HOME/.config/libreoffice folder. Go to HOME/.config/libreoffice/3/user and look for a file named registrymodifications.xcu. Delete the file. LibreOffice will recreate it for you. You will no longer get the window telling you that the templates already exist.

edit flag offensive delete link more

Comments

This also fixes the "File -> Send -> Create master document" I/O error on GNU/Linux Debian 9 (LibreOffice 6.0.2).

Please note that this modification will reset some settings, so you'll need to reconfigure LibreOffice and check the document properties (from the File menu) before distributing the next documents.

You saved my day @MannDTP. ;-)

Lorenzo Ancora gravatar imageLorenzo Ancora ( 2018-04-19 13:21:34 +0200 )edit
1

answered 2012-02-22 14:40:44 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

in Linux the libreoffice directory to delete is usually HOME/.libreoffice or HOME/.config/.libreoffice/

This fixed the template error as well as the recent documents empty error on Ubuntu and Mint.

edit flag offensive delete link more

Comments

Thank you. I found that and deleted it. Problem is that a lot of other information was lost. Hopefully they will fix this so there is no need to delete either the older installed version or the config folder. Thanks

leon244 gravatar imageleon244 ( 2012-02-22 16:38:20 +0200 )edit
1

answered 2012-02-29 13:19:31 +0200

Tshele gravatar image
  1. In windows 7, I enabled view hidden files.
  2. I renamed the LibreOffice directory in the C:\username\Appdata\roaming\libreoffice\ where I renamed the user folder.
  3. Opened libreoffice and allowed it to update its user details.
  4. Checked on the templates and found that I could now open the templates.
edit flag offensive delete link more
0

answered 2012-02-21 17:06:21 +0200

Askoli gravatar image

Same problem! My system is Windows XP SP3 Home Edition. Language Finnish When starting LibreOffice Writer 3.5 this pop-up appears: templates already exist (my version is Finnish) It does not allow me to save new template I greated. I deleted 3.5 and took back 3.4.5 which work very well.

edit flag offensive delete link more
0

answered 2012-05-15 23:48:06 +0200

celem gravatar image

Thanks. I use Mint 9 Linux. Deleting HOME/.config/.libreoffice/registrymodifications.xcu fixed the problem for me.

edit flag offensive delete link more
0

answered 2012-02-20 19:03:17 +0200

drone27of1 gravatar image
edit flag offensive delete link more
0

answered 2012-02-21 22:49:15 +0200

Mark12547 gravatar image

updated 2012-02-21 22:52:28 +0200

I came across the answer when tracking down the Empty "Recent Documents" list.

This will undo all of one's settings.

These steps are for Windows XP SP3.

  1. I closed all LibreOffice windows and exited the QuickStart
  2. I renamed the LibreOffice directory in the C:\Documents and Settings\username\Application Data directory.
  3. I started up LibreOffice (double-clicked on shortcut) and let it recreate the user's LibreOffice directory.
  4. I went into Tools --> Options... and updated various settings in there (name, country, which dictionaries to use, which Java runtime to use).
  5. I selected Text Document and opened an .ott (template) file. It went through its first-time template use, but there were no errors and the new document opened just fine.

Now opening a template to create a new document works just fine.

Also, now the Recent Documents list works just fine.

Also, the help pack works just fine!

(That means renaming the user's LibreOffice directory fixed all three bugs I had hit in the past 12 hours!)

However, the words I added to my dictionary are gone, and the toolbars are now reverted back to the standard ones. Fortunately, I had made very few changes in toolbars and the words are easy to add back as I use them.

edit flag offensive delete link more
0

answered 2012-02-20 21:45:44 +0200

Moonlight gravatar image

Same problem on Windows Vista System. Haven't found any solution for this. Hope this bug will be solved in the next update of LibreOffice .

edit flag offensive delete link more
0

answered 2012-03-20 03:12:39 +0200

Windows 7 users: 1. Close LL 2. Delete registrymodifications.xcu in your \users*username*\AppData\Roaming\LibreOffice\ folder. 3. Restart LO and templates will now function properly.

edit flag offensive delete link more
0

answered 2012-03-13 17:27:08 +0200

Louis gravatar image

updated 2012-03-13 17:30:39 +0200

Hai TNX MannDTP!! for me the same 'templates already exist' message, and than no deal. I deleted the file 'registrymodifications.xcu'. After that all templates and stuff where there. All working fine after setting them back again as defaults, just as ManDTP suggested. only I had to deal with a second location where the culprit lived: ~mine/.libreoffice/3/user/
system used: Linux-Mint 10.04 / libreoffice3.5

I suppose all you win users most have almost the same set of dir's where your libreoffice config-file's will live Try to delete the same 'registrymodifications.xcu'... and cross your thumbs

Louis

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2012-02-20 18:34:42 +0200

Seen: 3,012 times

Last updated: May 15 '12