Ask Your Question
0

Mac: hyphenation package

asked 2020-04-24 11:40:47 +0200

Molino gravatar image

updated 2020-08-18 15:03:38 +0200

Alex Kemp gravatar image

Just installed 6.4.3 (on MacOS 10.14.6). It's fine but some (not all) Writer documents now display a warning: 'Missing hyphenation info - Please install the hyphenation package for locale "en".' I've searched diligently but can't find such a thing. The closest I can get is the English dictionaries extension - is that what's needed? Or - an answer to a related question suggested the Terminal command 'sudo apt install hyphen-en-gb' - is that what I should do?

edit retag flag offensive close merge delete

Comments

Dictionary extensions often include hyphenation modules, but not always. Refer to the respective description.

gabix gravatar imagegabix ( 2020-04-24 12:07:14 +0200 )edit
1

'sudo apt install hyphen-en-gb'

This applies to Debian based Linux systems (Ubuntu and derivatives like Mint), but not to macOS.

Opaque gravatar imageOpaque ( 2020-04-24 12:12:30 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2020-04-24 19:04:14 +0200

Molino gravatar image

The answer turned out to be pleasantly simple. In the LibreOffice menu > Preferences > Language Settings > Writing Aids several dictionaries were listed and active but Libhyphen Hyphenator was unchecked. So I checked it and now all is well. I don't want to use auto hyphenation but the error messages were irritating!

edit flag offensive delete link more
0

answered 2021-05-04 07:12:09 +0200

BrianRoper gravatar image

updated 2021-05-04 07:13:45 +0200

To avoid the message "Missing hyphenation data Please install the hyphenation package for locale"

You don't need to install any package/s.

Keep the Libhyphen Hyphenator unchecked.

Styles, Edit Style, Text flow, uncheck Hyphenation Automatically, Ok. Save and close your file. Then re-open. Does unwanted nag message appear ?

HTH

edit flag offensive delete link more

Comments

Thanks for this. I tested it on one of my problem files and found it didn't work using the Styles menu but it's on the right lines. What worked was to highlight all the text (command-A) then Format > Paragraph > Text Flow > untick auto hyphenation.

Molino gravatar imageMolino ( 2021-05-04 10:11:04 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2020-04-24 11:40:47 +0200

Seen: 4,570 times

Last updated: May 04